summaryrefslogtreecommitdiff
path: root/gnu/packages/apr.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-10 21:44:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-10 21:44:32 +0200
commit1c055d72585bd075e20ad0b41942d501d0b38656 (patch)
tree7baf50e22fb5f6c6d4b2fa7197596f68298eb691 /gnu/packages/apr.scm
parent565e24c4e4710a5b81cce5cfb619b3e474e7f65c (diff)
parentffb4da7ad5c0e9cc969e0e47a3b8f4d2eba4d6f3 (diff)
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/apr.scm')
-rw-r--r--gnu/packages/apr.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/apr.scm b/gnu/packages/apr.scm
index 17945c0390..baadb41b60 100644
--- a/gnu/packages/apr.scm
+++ b/gnu/packages/apr.scm
@@ -80,19 +80,18 @@ around or take advantage of platform-specific deficiencies or features.")
`(("expat" ,expat)))
(arguments
'(#:phases
- (alist-replace
- 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (apr (assoc-ref inputs "apr"))
- (expat (assoc-ref inputs "expat")))
- (setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)
- (string-append "--with-apr=" apr)
- (string-append "--with-expat=" expat)))))
- %standard-phases)
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (apr (assoc-ref inputs "apr"))
+ (expat (assoc-ref inputs "expat")))
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (zero?
+ (system* "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--with-apr=" apr)
+ (string-append "--with-expat=" expat)))))))
;; There are race conditions during 'make check'. Typically, the
;; 'testall' executable is not built yet by the time 'make check' tries