summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-07-02 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:01 +0200
commit0cd3858d33f83364859276c171dc4746eeb5bbe8 (patch)
tree62b225ae886cb9738901264ae5ea4de9a80e9139 /gnu/packages/astronomy.scm
parentb85ae5e568a5057b194039f5f9b8e953adcd852b (diff)
gnu: skymaker: Update to 4.2.0-0.1a69c47.
* gnu/packages/astronomy.scm (skymaker): Update to 4.2.0-0.1a69c47. [source]: Use GIT-FETCH and GIT-FILE-NAME. [arguments]: Remove upstreamed -fcommon work-around. [native-inputs]: Add autoconf, automake, libtool, and pkg-config. Co-authored-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm61
1 files changed, 34 insertions, 27 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 3e5a227522..6126ac7f35 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -955,36 +955,43 @@ interactively in the plotting window.")
(license license:gpl2+)))
(define-public skymaker
- (package
- (name "skymaker")
- (version "3.10.5")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://www.astromatic.net/download/skymaker/"
- "skymaker-" version ".tar.gz"))
- (sha256
- (base32 "03zvx7c89plp9559niqv5532r233kza3ir992rg3nxjksqmrqvx1"))))
- (build-system gnu-build-system)
- (arguments
- (list
- #:configure-flags
- #~(list
- "CPPFLAGS=-fcommon" ; fix build with GCC 10
- (string-append
- "--with-fftw-libdir=" #$(this-package-input "fftwf") "/lib")
- (string-append
- "--with-fftw-incdir=" #$(this-package-input "fftwf") "/include"))))
- (inputs
- (list fftwf))
- (home-page "https://www.astromatic.net/software/skymaker")
- (synopsis "Astronomical image simulator")
- (description
- "SkyMaker is a program that simulates astronomical images. It accepts
+ ;; XXX: No version tag available in GitHub.
+ ;; See: https://github.com/astromatic/skymaker/issues/3
+ (let ((commit "1a69c4716bdc9b5c6d4a917b0bc2dbd47635c459")
+ (revision "0"))
+ (package
+ (name "skymaker")
+ (version (git-version "4.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/skymaker")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vin4vgvcmqmwjdchsxnap374559rksz55xmaliawnl3qpzxn1nk"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list
+ (string-append
+ "--with-fftw-libdir=" #$(this-package-input "fftwf") "/lib")
+ (string-append
+ "--with-fftw-incdir=" #$(this-package-input "fftwf") "/include"))))
+ (native-inputs
+ (list autoconf automake libtool pkg-config))
+ (inputs
+ (list fftwf))
+ (home-page "https://www.astromatic.net/software/skymaker")
+ (synopsis "Astronomical image simulator")
+ (description
+ "SkyMaker is a program that simulates astronomical images. It accepts
object lists in ASCII generated by the Stuff program to produce realistic
astronomical fields. SkyMaker is part of the EFIGI
(@url{https://www.astromatic.net/projects/efigi}) development project.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public stackistry
(package