summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-04-21 21:04:46 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-05-07 10:37:54 -0400
commit192426f2f6d81544ebac525080824d96f3382a4d (patch)
tree63e382be90be392acf907a3650ba92ebd3198055 /gnu/packages/astronomy.scm
parent7dac6fee5d26c977d215b1c31ef332b5910e699d (diff)
gnu: python-astroalign: Update to 2.4.2.
* gnu/packages/astronomy.scm (python-astroalign): Update to 2.4.2. [source]: Use git checkout instead PyPI to enable tests. [build-system]: Use pyproject-build-system. [propagated-inputs]: Migrate from inputs. Remove labels. Add optional python-bottleneck. [native-inputs]: Add python-astropy, python-ccdproc, python-pillow. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm29
1 files changed, 16 insertions, 13 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 0367725795..cf83d31340 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3035,22 +3035,25 @@ default) to world coordinates.")
(define-public python-astroalign
(package
(name "python-astroalign")
- (version "2.3.1")
+ (version "2.4.2")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "astroalign" version))
+ ;; There are no tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/quatrope/astroalign")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "19qzv3552lgrd9qmj0rxs51wmx485hw04cbf76ds5pin85kfaiy1"))))
- (build-system python-build-system)
- (arguments
- ;; TODO: (Sharlatan-20210213T162940+0000): I could not make tests run
- `(#:tests? #f))
- (inputs
- `(("numpy" ,python-numpy)
- ("scikit-image" ,python-scikit-image)
- ("scipy" ,python-scipy)
- ("sep" ,python-sep)))
+ (base32 "0hly20a65540hr3l1lsd1i4d90a0vdrbwnn6zx3z8s89ha9lq3pb"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-astropy python-ccdproc python-pillow))
+ (propagated-inputs
+ (list python-bottleneck
+ python-numpy
+ python-scikit-image
+ python-scipy
+ python-sep))
(home-page "https://astroalign.readthedocs.io/")
(synopsis "Astrometric Alignment of Images")
(description