summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-06-25 22:28:14 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-02 02:00:00 +0200
commitd62ceb7328eee6fccbecd212f4e7d9a6d9681aa1 (patch)
tree3107cd4c192e3f47382f3090b76a0b6209729428 /gnu/packages/astronomy.scm
parent818405bb42d8ed157b007eb69b007183a2521dfd (diff)
gnu: swarp: Update to 2.41.5.
* gnu/packages/astronomy.scm (swarp): Update to 2.41.5. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add automake, autoconf, libtool, and pkg-config. [inputs]: Add cfitsio. Co-authored-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index bcc17b1056..b7dc45338c 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1130,15 +1130,21 @@ project.")
(define-public swarp
(package
(name "swarp")
- (version "2.38.0")
+ (version "2.41.5")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://www.astromatic.net/download/swarp/"
- "swarp-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astromatic/swarp")
+ (commit (string-append version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1i670waqp54vin1cn08mqckcggm9zqd69nk7yya2vvqpdizn6jpm"))))
+ (base32 "00463r5rd4xl74xs4h1n4gl2qk7v9p5nw9x05pbzgh8jm77q90qq"))))
(build-system gnu-build-system)
+ (native-inputs
+ (list automake autoconf libtool pkg-config))
+ (inputs
+ (list cfitsio))
(home-page "https://www.astromatic.net/software/swarp")
(synopsis "FITS image resampling and co-addition")
(description