summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-30 20:58:45 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:23 +0300
commit2b085c4b41cd0aa888d9f4c027a23c483a7c73e5 (patch)
treee1e705b3660f4652bab59c0d835e7a946bb65d52 /gnu/packages/astronomy.scm
parent2095fe7b9671b69b060dff8be2a4eea89cd61923 (diff)
gnu: Add python-wiimatch.
* gnu/packages/astronomy.scm (python-wiimatch): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index f2ef829ca9..1655fd09aa 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3528,3 +3528,26 @@ astronomical images, especially when there is no WCS information available.")
"Skyfield computes positions for the stars, planets, and satellites in
orbit around the Earth.")
(license license:expat)))
+
+(define-public python-wiimatch
+ (package
+ (name "python-wiimatch")
+ (version "0.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "wiimatch" version))
+ (sha256
+ (base32
+ "0x6p5z6a2cqinckwlpinjxagvmswl149s1jn6ihmdxk4k0h8rrz0"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-numpy python-scipy))
+ (native-inputs (list python-codecov python-pytest python-pytest-cov
+ python-pytest-doctestplus python-setuptools-scm))
+ (home-page "https://github.com/spacetelescope/wiimatch")
+ (synopsis
+ "Optimal matching of weighted N-dimensional image intensity data")
+ (description
+ "@code{wiimatch} is a package that provides core computational algorithms
+for optimal @code{matching} of weighted N-dimensional image intensity data
+using (multivariate) polynomials.")
+ (license license:bsd-3)))