summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-30 20:58:48 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:23 +0300
commit339be9dad527bb0805e35dc1816cf373d445ed91 (patch)
tree665298b071627ee09b1ec8a88969e8455ded8a13 /gnu/packages/astronomy.scm
parent37bfbd4fcffc22d72dbd3aff1dd98866571479fe (diff)
gnu: Add python-jwst.
* gnu/packages/astronomy.scm (python-jwst): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm67
1 files changed, 67 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 507bff7835..cdb6750f09 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2926,6 +2926,73 @@ Moon position, etc.")
JPL ephemerides use to predict raw (x,y,z) planetary positions.")
(license license:expat)))
+(define-public python-jwst
+ (package
+ (name "python-jwst")
+ (version "1.10.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "jwst" version))
+ (sha256
+ (base32
+ "1lmfyw2y7c84rs9xqavah9aidj478ijiiijlz6fag11xqn1vs98y"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; XXX: Tests require access to https://jwst-crds-pub.stsci.edu server for
+ ;; getting data sets.
+ #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ ;; NOTE: (Sharlatan-20230529T113448+0100): opencv-python's
+ ;; version can't be detected, it could the way it's packed in
+ ;; Guix. Review failing sanity check with more efforts,
+ ;; disable for now to make package buildable.
+ (delete 'sanity-check))))
+ ;; opencv provides OpenCV-Python which is Listed as install requirement.
+ (propagated-inputs (list opencv
+ python-asdf
+ python-asdf-astropy
+ python-astropy
+ python-bayesicfitting
+ python-crds
+ python-drizzle
+ python-gwcs
+ python-jsonschema
+ python-numpy
+ python-photutils
+ python-poppy
+ python-psutil
+ python-pyparsing
+ python-requests
+ python-scikit-image
+ python-scipy
+ python-spherical-geometry
+ python-stcal
+ python-stdatamodels
+ python-stpipe
+ python-stsci-image
+ python-stsci-imagestats
+ python-tweakwcs
+ python-wiimatch))
+ (native-inputs (list python-codecov
+ python-colorama
+ python-flake8
+ python-pytest
+ python-pytest-cov
+ python-pytest-doctestplus
+ python-pytest-openfiles
+ python-requests-mock
+ python-setuptools-scm))
+ (home-page "https://jwst-pipeline.readthedocs.io/en/latest/")
+ (synopsis
+ "Python library for science observations from the James Webb Space Telescope")
+ (description
+ "This package provides an access to the JWST Science Calibration Pipeline
+processes data from all JWST instruments and observing modes by applying various
+science corrections sequentially, producing both fully-calibrated individual
+exposures and high-level data products (mosaics, extracted spectra, etc.).")
+ (license license:bsd-3)))
+
(define-public python-pyerfa
(package
(name "python-pyerfa")