summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-27 21:39:22 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-27 22:51:59 +0000
commit6b0551a6bb890fd64490c933b697fc4ff321f3de (patch)
tree435d46faa9bb48839be2b0b0c69a663e622db647 /gnu/packages/astronomy.scm
parentb515ca6eb8a7fe9407115b3432119d00e11d12fc (diff)
gnu: python-spectral-cube: Speed up tests.
* gnu/packages/astronomy.scm (python-spectral-cube): Enable parallel tests to speed them up. [arguments] <#:test-flags>: Add it with "-n" option. [propagated-inputs]: Remove python-aplpy. [native-inputs]: Add python-pytest-xdist. Change-Id: Icd5afb95ea64406a2f61e4d395bfe503c668cf12
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 6a9c7e3183..69b2af63d7 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2730,9 +2730,17 @@ elevation, solar azimuth, rahukaalam, and the phases of the moon.")
(sha256
(base32 "0cqxgmk46gv2qa2kls8fph105lgwbwf13hvizh6w85mzgypyp740"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "-n" "auto")))
(propagated-inputs
(list python-astropy
- python-aplpy
+ ;; XXX: Currently failing in upstream as it's optional silent
+ ;; until a new version is released, see:
+ ;; <https://github.com/aplpy/aplpy/issues/492>.
+ ;;
+ ;; python-aplpy
python-casa-formats-io
python-dask
python-distributed
@@ -2752,6 +2760,7 @@ elevation, solar azimuth, rahukaalam, and the phases of the moon.")
;; in [noviz] option.
;; python-pvextractor
python-pytest-astropy
+ python-pytest-xdist
python-regions
python-semantic-version
python-setuptools-scm))