summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-24 22:51:43 +0100
committerVinicius Monego <monego@posteo.net>2023-05-25 21:20:05 -0300
commitee9dfc1dda5e8bd8b92f49b0c1e1e503cc29c0ad (patch)
treed66f35486cac19f6b84e86127574e196a9098bd8 /gnu/packages/astronomy.scm
parente811fa139f570ca1dc7b87b993ceefefbffd3f44 (diff)
gnu: python-pyvo: Update to 1.4.1.
* gnu/packages/astronomy.scm (python-pyvo): Update to 1.4.1. [build-system]: Switch to pyproject-build-system. [arguments]: Do not override the 'check phase. [native-inputs]: Add python-setuptools-scm. Signed-off-by: Vinicius Monego <monego@posteo.net>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm19
1 files changed, 4 insertions, 15 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 93762c3558..a3a037a853 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1723,27 +1723,16 @@ interest, and which require portability between platforms or ease of scripting."
(define-public python-pyvo
(package
(name "python-pyvo")
- (version "1.2.1")
+ (version "1.4.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyvo" version))
(sha256
- (base32 "1ri5yp6903386lkn79mdcmlax7zsfrrrjbcvb91wxydcc9yasc1n"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest" "--pyargs" "pyvo" "-k"
- (string-append ; these tests use the network
- "not test_access_with_string"
- " and not test_access_with_list"
- " and not test_access_with_expansion"))))))))
+ (base32 "17acv1yhz1jrsx9f35nr1vg276ibaivh4i243qkmp6abzvfyg907"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pytest-astropy python-requests-mock))
+ (list python-pytest-astropy python-requests-mock python-setuptools-scm))
(propagated-inputs
(list python-astropy python-mimeparse python-pillow python-requests))
(home-page "https://github.com/astropy/pyvo")