summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-07-23 22:00:44 +0100
committerLudovic Courtès <ludo@gnu.org>2022-08-01 14:08:07 +0200
commit6ad9a094c1a25a4aa1df559943f9bc6ca8870752 (patch)
tree4e2d416a842f1aba46f47807b32db00007acc313 /gnu/packages/astronomy.scm
parent5a96748a9975e5144f07ad8178097f8e6146f197 (diff)
gnu: Add libsep
* gnu/packages/astronomy.scm: (libsep): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index acac8449ab..7718e92efa 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1131,6 +1131,48 @@ Mechanics, Astrometry and Astrodynamics library.")
(license (list license:lgpl2.0+
license:gpl2+)))) ; examples/transforms.c & lntest/*.c
+(define-public libsep
+ (package
+ (name "libsep")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kbarbary/sep")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0sag96am6r1ffh9860yq40js874362v3132ahlm6sq7padczkicf"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (chdir "../source")
+ (invoke "make"
+ (string-append "CC=" #$(cc-for-target))
+ "test")))))))
+ (native-inputs
+ (list python-wrapper))
+ (home-page "https://github.com/kbarbary/sep")
+ (synopsis "Astronomical source extraction and photometry library")
+ (description
+ "SEP makes the core algorithms of
+@url{https://www.astromatic.net/software/sextractor/, sextractor} available as a
+library of stand-alone functions and classes. These operate directly on
+in-memory arrays (no FITS files or configuration files). The code is derived
+from the Source Extractor code base (written in C) and aims to produce results
+compatible with Source Extractor whenever possible. SEP consists of a C library
+with no dependencies outside the standard library, and a Python module that
+wraps the C library in a Pythonic API. The Python wrapper operates on NumPy
+arrays with NumPy as its only dependency.")
+ (license (list license:expat license:lgpl3+ license:bsd-3))))
+
(define-public libskry
(package
(name "libskry")