summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2022-08-13 16:25:31 -0700
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2022-09-21 22:07:27 +0200
commit97e719593045f5541d062aece1a25379be56d24d (patch)
tree9fe97fb0d7aee7e2a1174d7b3129ceba660ffac1 /gnu/packages/astronomy.scm
parentfff6407df39e624dac6538eea27d182612a4d765 (diff)
gnu: Add python-ephem.
* gnu/packages/astronomy.scm (python-ephem): New Variable. Signed-off-by: Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 87c290f58f..13ffdd74d3 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -29,6 +29,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -1054,6 +1055,29 @@ attempting to maintain ISTP compliance
@end itemize\n")
(license license:expat)))
+(define-public python-ephem
+ (package
+ (name "python-ephem")
+ (version "4.1.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "ephem" version))
+ (sha256
+ (base32
+ "0smmm3l8csnw9rrimh8mpyjrm80jaafjl184spnji98vk22qd8bz"))))
+ (build-system python-build-system)
+ (native-inputs (list tzdata))
+ (home-page "https://rhodesmill.org/pyephem/")
+ (synopsis "Compute positions of the planets and stars")
+ (description
+ "PyEphem provides an @code{ephem} Python package for performing
+high-precision astronomy computations.
+
+The name ephem is short for the word ephemeris, which is the traditional term
+for a table giving the position of a planet, asteroid, or comet for a series
+of dates.")
+ (license license:expat)))
+
(define-public python-photutils
(package
(name "python-photutils")