summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-05-23 23:44:58 +0100
committerLudovic Courtès <ludo@gnu.org>2023-02-25 00:00:34 +0100
commitb12ee1ee5b8b53bf27b79ce81b1b2158cc7de484 (patch)
tree91db21123edda32a388563e3ad224acb508528a7 /gnu/packages/astronomy.scm
parent3164d48e55b2d614bcd8def064d4671578617963 (diff)
gnu: Add python-spherical-geometry.
* gnu/packages/astronomy.scm (python-spherical-geometry): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 02d6dc0aa1..b6ed1e2f49 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -54,6 +54,7 @@
#:use-module (gnu packages libusb)
#:use-module (gnu packages lua)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages netpbm)
#:use-module (gnu packages perl)
@@ -1680,6 +1681,54 @@ positions of the sun: dawn, sunrise, solar noon, sunset, dusk, solar
elevation, solar azimuth, rahukaalam, and the phases of the moon.")
(license license:asl2.0)))
+(define-public python-spherical-geometry
+ (package
+ (name "python-spherical-geometry")
+ (version "1.2.22")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/spacetelescope/spherical_geometry")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0kzcncqir4v7nhk9lxj9gxr32p3krkaqa58y2i4kksgxxy24qw4z"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ ;; NOTE: (Sharlatan-20220523T231348+0100): Tests depends on old Python2
+ ;; libarry `sphere'
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'preparations
+ (lambda _
+ ;; Fixing: setuptools-scm was unable to detect version for ...
+ (substitute* "setup.py"
+ (("use_scm_version=True")
+ (format #f "version=~s" #$version))
+ (("setup_requires=\\['setuptools_scm'\\],.*")
+ ""))
+ ;; Use our own libraries in place of bundles.
+ (setenv "USE_SYSTEM_QD" "1"))))))
+ (native-inputs
+ (list python-pytest
+ python-setuptools-scm))
+ (inputs
+ (list qd))
+ (propagated-inputs
+ (list python-astropy
+ python-numpy))
+ (home-page "https://github.com/spacetelescope/tweakwcs")
+ (synopsis "Python astronimical package for handling spherical polygons")
+ (description
+ "The @code{spherical_geometry} library is a Python package for handling
+spherical polygons that represent arbitrary regions of the sky.")
+ ;; LICENSE.rst Association of Universities for Research in Astronomy (AURA)
+ ;; QD_LIBRARY_LICENSE.rst for bandeled QD source
+ (license license:bsd-3)))
+
(define-public libnova
(package
(name "libnova")