summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-12-11 22:25:43 +0000
committerLudovic Courtès <ludo@gnu.org>2023-01-06 23:46:31 +0100
commitd86ac0008fcc362b0f2afb53e7006e0ec41a7a24 (patch)
tree66b5f3b501a38c7a4c0d43d990445d5b6a4c6d2c /gnu/packages/astronomy.scm
parent888942a155bfe6c2c8d34064b02b4d14c6aa7e63 (diff)
gnu: wcslib: Update to 7.12.
* gnu/packages/astronomy.scm (wcslib): Update to 7.12. [arguments]: Use Gexp, enable parallel tests. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 289fc8e25f..01905ce990 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -525,7 +525,7 @@ feature detection and cosmetic corrections.")
(define-public wcslib
(package
(name "wcslib")
- (version "7.5")
+ (version "7.12")
(source
(origin
(method url-fetch)
@@ -533,26 +533,26 @@ feature detection and cosmetic corrections.")
"ftp://ftp.atnf.csiro.au/pub/software/wcslib/wcslib-" version
".tar.bz2"))
(sha256
- (base32 "1536gmcpm6pckn9xrb6j8s4pm1vryjhzvhfaj9wx3jwxcpbdy0dw"))))
+ (base32 "1m3bx6gh5w3c7vvsqcki0x20mg8lilg13m0i8nh7za89w58dxy4w"))))
(inputs
(list cfitsio))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
- (list (string-append "--with-cfitsiolib="
- (assoc-ref %build-inputs "cfitsio") "/lib")
- (string-append "--with-cfitsioinc="
- (assoc-ref %build-inputs "cfitsio") "/include"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-/bin/sh
- (lambda _
- (substitute* "makedefs.in"
- (("/bin/sh") "sh"))
- #t))
- (delete 'install-license-files)) ; installed by ‘make install’
- ;; Parallel execution of the test suite is not supported.
- #:parallel-tests? #f))
+ (list
+ #:configure-flags
+ #~(list (string-append "--with-cfitsiolib="
+ #$(this-package-input "cfitsio") "/lib")
+ (string-append "--with-cfitsioinc="
+ #$(this-package-input "cfitsio") "/include"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'install-license-files) ; installed by ‘make install’
+ (add-before 'configure 'patch-/bin/sh
+ (lambda _
+ (substitute* "makedefs.in"
+ (("/bin/sh") "sh")))))))
+ ;; TODO: Fix build with gfortran and pack missing optional pgplot.
+ ;; (inputs (list gfortran pgplot))
(home-page "https://www.atnf.csiro.au/people/mcalabre/WCS")
(synopsis "Library which implements the FITS WCS standard")
(description "The FITS \"World Coordinate System\" (@dfn{WCS}) standard