summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-15 16:50:08 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-27 22:52:00 +0000
commit9a33695a158bd7e6cca4f5b5ca707b08b7c04de6 (patch)
tree3cc86e272620853f7a297e87fec5cef3aa881a51 /gnu/packages/astronomy.scm
parent55ded0719c98a96870b86c3143c281d22de041a3 (diff)
gnu: python-poliastro: Relax requirements.
* gnu/packages/astronomy.scm (python-poliastro) [arguments] <#:phases>: Add 'relax-requirements phase. Change-Id: Idb75f1ee9e0b9646024fab0a1d17ea50ca63a7f5
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 54b8e66931..6324d941a8 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2264,6 +2264,9 @@ can be described by @acronym{WCS, World Coordinate System} translations.")
of astronomical sources.")
(license license:bsd-3)))
+;; XXX: The project is archived, maintained fork is available see
+;; <https://github.com/poliastro/poliastro/issues/1640>.
+;; Maintained fork <https://github.com/pleiszenburg/hapsira>.
(define-public python-poliastro
(package
(name "python-poliastro")
@@ -2296,6 +2299,10 @@ of astronomical sources.")
" and not test_porkchop_plotting"))
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "pyproject.toml"
+ (("5.0,<6") "5.0,<7"))))
(add-after 'unpack 'matplotlib-compatibility
(lambda _
(substitute* "src/poliastro/plotting/static.py"