summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-27 15:54:04 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-27 22:51:57 +0000
commit6b07d8a9165d7c1c9cb5d013396dc327d7d1bfd2 (patch)
treeb805749d5bc282c2f23b100aefba2231f0b74472 /gnu/packages/astronomy.scm
parent38b6670c7a82376e0e2d256b547d080f0e07e8ae (diff)
gnu: python-asdf-2.15: Deprecate package.
Version 2.15.0 is no longer built with the python-astropy v6.0.0, fail over to the latest version. * gnu/package/astronomy.scm (python-asdf-2.15): Remove variable. * gnu/package/astronomy.scm (python-asdf): Fail over to python-asdf-3.0. Change-Id: I30b97c42f672571783f900825098af12c773ac87
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm32
1 files changed, 2 insertions, 30 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 9db5b080cc..cb645ea558 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2973,7 +2973,7 @@ image processing functions: @code{xyxymatch}, @code{geomap}.")
(invoke "python" "setup.py" "build_ext" "--inplace"))))))
(propagated-inputs
(list opencv ;Provides OpenCV-Python
- python-asdf-3.0
+ python-asdf
python-astropy
python-gwcs
python-numpy
@@ -4057,7 +4057,7 @@ between image and reference catalogs. Currently only aligning images with
@code{FITS WCS} and @code{JWST gWCS} are supported.")
(license license:bsd-3)))
-(define-public python-asdf-3.0
+(define-public python-asdf
(package
(name "python-asdf")
(version "3.0.1")
@@ -4095,34 +4095,6 @@ interchange format for scientific data. This package contains the Python
implementation of the ASDF Standard.")
(license license:bsd-3)))
-(define-public python-asdf-2.15
- (package
- (inherit python-asdf-3.0)
- (version "2.15.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "asdf" version))
- (sha256
- (base32 "11s56797l5330kkhppkyz0bsvms016knmyswj4gx91zrxf8iqvv8"))))
- (arguments
- (list #:test-flags
- #~(list "-k" (string-append
- "not test_overwrite"
- " and not test_tagging_scalars"
- " and not test_info_command"
- " and not test_array_inline_threshold_recursive"))))
- (native-inputs
- (modify-inputs (package-native-inputs python-asdf-3.0)
- (prepend python-astropy python-pytest-openfiles)))
- (propagated-inputs
- (modify-inputs (package-propagated-inputs python-asdf-3.0)
- (prepend python-jsonschema python-importlib-resources)))))
-
-(define-public python-asdf
- ;; Default version of ASDF..
- python-asdf-2.15)
-
(define-public python-asdf-standard
(package
(name "python-asdf-standard")