summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-14 21:15:43 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-24 22:24:37 +0000
commit8084df8b107823c829aa9271a80b6f23680d64cc (patch)
treef8dcbb02cd96d6f2910defa5a2e0e15ce921f823 /gnu/packages/astronomy.scm
parent4a68e6aabff0ff7b50bab220cc965e1536e38c82 (diff)
gnu: python-stcal: Update to 1.5.2.
* gnu/packages/astronomy.scm (python-stcal): Update to 1.5.2. [propagated-inputs]: Add python-asdf-3.0 and python-gwcs. [native-inputs]: Remove python-cython; add python-cython-3 and python-semantic-version. Change-Id: I8b6a90a3c0b75ee43de4c7069950a4f9578ea825
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 4c867aa66a..ce84b50e54 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2775,13 +2775,13 @@ image processing functions: @code{xyxymatch}, @code{geomap}.")
(define-public python-stcal
(package
(name "python-stcal")
- (version "1.4.4")
+ (version "1.5.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "stcal" version))
(sha256
- (base32 "031ldihdmsdrwz4wl49bfk2bxmzbp1i3kidrw46xz936765zmnc0"))))
+ (base32 "0r1a9f476f8ivhrwbcny3rnj9s4plaps6p36c22w73g546d476b7"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -2796,16 +2796,19 @@ image processing functions: @code{xyxymatch}, @code{geomap}.")
(invoke "python" "setup.py" "build_ext" "--inplace"))))))
(propagated-inputs
(list opencv ;Provides OpenCV-Python
+ python-asdf-3.0
python-astropy
+ python-gwcs
python-numpy
python-scipy))
(native-inputs
- (list python-cython
+ (list python-cython-3
python-psutil
python-pytest
python-pytest-cov
python-pytest-doctestplus
python-pytest-openfiles
+ python-semantic-version
python-setuptools-scm))
(home-page "https://github.com/spacetelescope/stcal")
(synopsis "STScI tools and algorithms used in calibration pipelines")