summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-14 23:08:13 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-24 22:24:37 +0000
commita75c4114f8b01bfe79c85df86b8a0bcbfe6a9677 (patch)
tree65f108f8167b53ee0b8fb0262b1a4d00c367abc9 /gnu/packages/astronomy.scm
parent5d390495ab01f0c388fd87d1724a012c50dca260 (diff)
gnu: Add python-ndcube.
* gnu/packages/astronomy.scm (python-ndcube): New variable. Change-Id: I94087c7e02ca678531bcbf4eb3d035e2647768fd
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d757fc75d9..1a11aac534 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2076,6 +2076,55 @@ of dates.")
the easy construction of interactive matplotlib widget based animations.")
(license license:bsd-3)))
+(define-public python-ndcube
+ (package
+ (name "python-ndcube")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ndcube" version))
+ (sha256
+ (base32 "1b3vbnm438j5jb48vilp145lq137fbrg1l4845rc55mz2p025x34"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-home-env
+ (lambda _
+ ;; Tests require HOME to be set.
+ ;; Permission denied: '/homeless-shelter'
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list python-astropy
+ python-gwcs
+ python-matplotlib
+ python-mpl-animators
+ python-numpy
+ python-reproject))
+ (native-inputs
+ (list python-dask
+ python-pytest
+ python-pytest-astropy
+ python-pytest-mpl
+ python-scipy
+ python-setuptools-scm
+ python-sunpy))
+ (home-page "https://docs.sunpy.org/projects/ndcube/")
+ (synopsis "Multi-dimensional contiguous and non-contiguous coordinate aware arrays")
+ (description
+ "@code{ndcube} is a package for manipulating, inspecting and visualizing
+multi-dimensional contiguous and non-contiguous coordinate-aware data arrays.
+
+It combines data, uncertainties, units, metadata, masking, and coordinate
+transformations into classes with unified slicing and generic coordinate
+transformations and plotting/animation capabilities. It is designed to handle
+data of any number of dimensions and axis types (e.g. spatial, temporal,
+spectral, etc.) whose relationship between the array elements and the real world
+can be described by @acronym{WCS, World Coordinate System} translations.")
+ (license license:bsd-2)))
+
(define-public python-photutils
(package
(name "python-photutils")