summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-11-07 23:06:48 +0000
committerChristopher Baines <mail@cbaines.net>2022-11-21 14:25:12 +0000
commit1b03c64a05a319631a82cd15b9dda914e94c5142 (patch)
tree26b1660d5eb69188503e3adb137400cd508a7966 /gnu/packages/astronomy.scm
parentd369a4cfa032d5f55847fd189df85a885456c019 (diff)
gnu: Add asdf-standard.
* gnu/packages/astronomy.scm (python-asdf-standard): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index bc31a12594..2eac10457d 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -78,6 +78,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix git-download)
@@ -1987,6 +1988,47 @@ interchange format for scientific data. This package contains the Python
implementation of the ASDF Standard.")
(license license:bsd-3)))
+(define-public python-asdf-standard
+ (package
+ (name "python-asdf-standard")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "asdf_standard" version))
+ (sha256
+ (base32
+ "0i7xdjwn5prg2hcnf1zhw57mszc68jjr5sv4rimpzcg7f2dgzn5g"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'remove-blocking-tests
+ (lambda _
+ ;; Remove tests require python-asdf where
+ ;; python-asdf require python-asdf-standard,
+ ;; break circular dependencies.
+ (for-each delete-file
+ (list "tests/test_manifests.py"
+ "tests/test_integration.py")))))))
+ (native-inputs (list python-astropy
+ python-jsonschema-next
+ python-pypa-build
+ python-pytest-7.1
+ python-packaging
+ python-setuptools-scm))
+ (propagated-inputs (list python-importlib-resources))
+ (home-page "https://asdf-standard.readthedocs.io/")
+ (synopsis "ASDF standard schemas")
+ (description
+ "This package provides Python implementation of @acronym{ASDF, Advanced
+Scientific Data Format} - a proposed next generation interchange format for
+scientific data. ASDF aims to exist in the same middle ground that made FITS
+so successful, by being a hybrid text and binary format: containing human
+editable metadata for interchange, and raw binary data that is fast to load
+and use. Unlike FITS, the metadata is highly structured and is designed
+up-front for extensibility.")
+ (license license:bsd-3)))
+
(define python-asdf-transform-schemas
(package
(name "python-asdf-transform-schemas")