summaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-11-07 23:06:50 +0000
committerChristopher Baines <mail@cbaines.net>2022-11-21 14:25:12 +0000
commit6924f4a866dbda02b15b075f7718d4aa794090f3 (patch)
treea5074a9a4173db374aa3270bd088aea636dabadc /gnu/packages/astronomy.scm
parentf99a1e257d7ba5995afcf05f429d79d6f097a517 (diff)
gnu: Add asdf-fits-schemas.
* gnu/packages/astronomy.scm (python-asdf-fits-schemas): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 2b3f0f61e2..ecacc72bde 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2094,6 +2094,41 @@ coordinates tags. Users should not need to install this directly; instead,
install an implementation package such as asdf-astropy.")
(license license:bsd-3)))
+(define python-asdf-fits-schemas
+ ;; TODO: No release, change to tag when it's ready.
+ (let ((commit "572bb370d777f3a325b25c1af9d76e1b7d27dcea")
+ (revision "0"))
+ (package
+ (name "python-asdf-fits-schemas")
+ (version (git-version "0.0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/asdf-format/asdf-fits-schemas")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yqnzd0gcrdfl0jqm8m8kz5fd36i8lgh7xkglmp1chsi1cc6mkz2"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; Dependency cycle with python-asdf
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-version
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" "0.0.1"))))))
+ (native-inputs (list python-setuptools-scm))
+ (propagated-inputs (list python-asdf-standard python-importlib-resources))
+ (home-page "https://github.com/asdf-format/asdf-fits-schemas")
+ (synopsis "ASDF schemas to support the FITS format")
+ (description
+ "This package provides ASDF schemas for validating FITS tags.")
+ (license license:bsd-3))))
+
(define python-asdf-unit-schemas
(package
(name "python-asdf-unit-schemas")