summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-25 18:28:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-25 18:29:45 +0100
commit9518c61e70e852736e1a554fd8fd4efd51166429 (patch)
treec42228b3f32402932cbe3ad0c05c8401d25fc37d /gnu/packages/audio.scm
parentd1f9519c0047609cb02b5a0db13da9824c754c7e (diff)
gnu: Add jack-example-tools.
* gnu/packages/audio.scm (jack-example-tools): New variable.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index c39e43c8a1..4fbfefafa3 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2466,6 +2466,36 @@ synchronous execution of all clients, and low latency operation.")
;; Most files are under GPLv2+, but some headers are under LGPLv2.1+
(license (list license:gpl2+ license:lgpl2.1+))))
+(define-public jack-example-tools
+ (package
+ (name "jack-example-tools")
+ (version "3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jackaudio/jack-example-tools")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x684clxqib1bq3zvvrqlh7hb3arb1bf672xyx1jbwv76dcmm5mh"))))
+ (build-system meson-build-system)
+ (inputs
+ (list alsa-lib
+ jack-2
+ libsndfile
+ opus
+ readline))
+ (native-inputs
+ (list pkg-config))
+ (home-page "https://github.com/jackaudio/jack-example-tools")
+ (synopsis "Tools for JACK connections")
+ (description "This package provides tools for managing JACK connections
+and testing or configuring the JACK session. Tools include @code{jack_lsp},
+@code{jack_connect}, and @code{jack_transport}.")
+ ;; Most files are under GPLv2+, but zalsa is GPLv3+.
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public jacktrip
(package
(name "jacktrip")