summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:26 +0200
commit9af6f1b624739179538d74866db7df6797cee31d (patch)
tree35cc6aa1cd52c434c48d8e77f95c55db5afb6612 /gnu/packages/audio.scm
parentcf6b06c1038b9fd4bf71b4a7583fe5fcf79cce57 (diff)
gnu: Add iir.
* gnu/packages/audio.scm (iir): New public variable.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 37a38bae89..94325ccb72 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1101,6 +1101,39 @@ guitar amplification and a small range of classic effects, signal processors and
generators of mostly elementary and occasionally exotic nature.")
(license license:gpl3+)))
+(define-public iir
+ (package
+ (name "iir")
+ (version "1.9.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/berndporr/iir1")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wbh804as740kjvmyaqx4rwvwwrbwh0fnj979dvv1ljlx1p50bk0"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'delete-static-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (delete-file (string-append out "/lib/libiir_static.a"))))))))
+ (home-page "https://berndporr.github.io/iir1/")
+ (synopsis
+ "Real-time C++ @acronym{IIR, infinite impulse response} filter library")
+ (description
+ "This C++ library implements the Butterworth, RBJ, and Chebychev
+@acronym{IIR, infinite impulse response} filters. Samples are processed one by
+one, in real time. It can easily import coefficients generated with Python
+(@code{scipy}). It also avoids memory leaks by allocating memory at compile
+time, using templates, instead of calling @code{malloc()} or @code{new}.")
+ (license license:expat)))
+
(define-public infamous-plugins
(package
(name "infamous-plugins")