summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-02-27 11:53:06 -0500
committerMark H Weaver <mhw@netris.org>2015-02-28 09:49:01 -0500
commit722ec722441a755e18fbc696d23441427dfb26af (patch)
tree8d429f0ec1b30d692ab24bc07838e47b4cb33ab8 /gnu/packages/audio.scm
parentdd0a8ef15f903422c6b020e7d793986427add927 (diff)
gnu: Move autoconf-style phases after the unpack phase.
* gnu/packages/audio.scm (soundtouch)[arguments]: Move 'bootstrap' after 'unpack'. Remove custom /usr/bin/file patching, which will now be handled by the 'patch-usr-bin-file' phase. * gnu/packages/emacs.scm (emacs-w3m)[arguments]: Rename 'pre-configure' phase to 'autoconf' and move it after 'unpack'. * gnu/packages/fontutils.scm (libuninameslist)[arguments]: Move 'bootstrap' phase after 'unpack'. * gnu/packages/libevent.scm (libuv)[arguments]: Move 'autogen' phase after 'unpack'. Run "sh autogen.sh" instead of "./autogen.sh". * gnu/packages/linux.scm (bridge-utils)[arguments]: Move 'bootstrap' phase after 'unpack'. * gnu/packages/mail.scm (libetpan)[arguments]: Move 'autogen' phase after 'unpack'. Run "sh autogen.sh" instead of "./autogen.sh". Setenv "NOCONFIGURE" before running autogen.sh. * gnu/packages/package-management.scm (guix-devel)[arguments]: Move 'bootstrap' phase after 'unpack'. Run "sh autogen.sh" instead of "./autogen.sh". * gnu/packages/rdf.scm (lrdf)[arguments]: Move 'autoreconf' phase after 'remove-out-of-tree-references' phase. * gnu/packages/tor.scm (privoxy)[arguments]: Move 'autoconf' phase after 'unpack'. * gnu/packages/web.scm (libpsl)[arguments]: Move 'bootstrap' phase after 'unpack'. Run "sh autogen.sh" instead of "./autogen.sh". Remove 'fix-autogen-shebang' phase.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 52feea3701..bc21c9f1f9 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -804,13 +804,10 @@ stretching and pitch scaling of audio. This package contains the library.")
("file" ,file)))
(arguments
'(#:phases
- (alist-cons-before
- 'configure 'bootstrap
+ (alist-cons-after
+ 'unpack 'bootstrap
(lambda _
- (unless (zero? (system* "sh" "bootstrap"))
- (error "bootstrap failed"))
- (substitute* '("configure")
- (("/usr/bin/file") "file")))
+ (zero? (system* "sh" "bootstrap")))
%standard-phases)))
(home-page "http://www.surina.net/soundtouch/")
(synopsis