summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-26 00:56:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-26 00:56:32 +0200
commit55036ddc9a096c2bdf573b8cffb2605ecc7e30f9 (patch)
treefb05cd9c0000d2dfc66a86ef23615a53906ee396 /gnu/packages/audio.scm
parent88507036f603ac1a65bf622e505d45d17f77f9f0 (diff)
gnu: soundtouch: Update to 2.1.1.
* gnu/packages/audio.scm (soundtouch): Update to 2.1.1. [source]: Use GIT-FETCH and GIT-FILE-NAME. Remove patches. * gnu/packages/patches/soundtouch-CVE-2018-1000223.patch, gnu/packages/patches/soundtouch-CVE-2018-14044-14045.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 7a79f4dcab..49fcc511e6 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2691,18 +2691,16 @@ Tracker 3 S3M and Impulse Tracker IT files.")
(define-public soundtouch
(package
(name "soundtouch")
- (version "2.0.0")
+ (version "2.1.1")
(source
(origin
- (method url-fetch)
- (uri
- (string-append
- "http://www.surina.net/soundtouch/soundtouch-" version ".tar.gz"))
- (patches (search-patches "soundtouch-CVE-2018-14044-14045.patch"
- "soundtouch-CVE-2018-1000223.patch"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/soundtouch/soundtouch.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "09cxr02mfyj2bg731bj0i9hh565x8l9p91aclxs8wpqv8b8zf96j"))))
+ (base32 "0p6jzgfgqw061702dmd2b6r4arz48ac3mmx2qkvvzf8s5jjzykdh"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)