summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-21 17:47:35 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-21 17:57:01 +0200
commit9b6dc31b6d0fa56e005c928453a6bc72cff9ae73 (patch)
treed7ddb84a8bac7009d5957e69e1f4f6ddad364e76 /gnu/packages/audio.scm
parentb6b3e5120ad3badba4f55af45b02667b662c1362 (diff)
gnu: fluidsynth: Update to 2.0.1.
* gnu/packages/audio.scm (fluidsynth): Update to 2.0.1. (fluidsynth-1): New public variable. * gnu/packages/games.scm (gzdoom)[inputs]: Change FLUIDSYNTH to FLUIDSYNTH-1. * gnu/packages/music.scm (lmms)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm21
1 files changed, 19 insertions, 2 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 5ec10b370e..a1745bb7a6 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@posteo.net>
+;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1041,7 +1042,7 @@ follower.")
(define-public fluidsynth
(package
(name "fluidsynth")
- (version "1.1.11")
+ (version "2.0.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1050,7 +1051,7 @@ follower.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0n75jq3xgq46hfmjkaaxz3gic77shs4fzajq40c8gk043i84xbdh"))))
+ "1mqyym5qkh8xd1rqj3yhfxbw5dxjcrljb6nkfqzvcarlv4h6rjn7"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; no check target
@@ -1082,6 +1083,22 @@ device. It is the software analogue of a MIDI synthesizer. FluidSynth can
also play midifiles using a Soundfont.")
(license license:lgpl2.1+)))
+;; gzdoom@3.3.0 and lmms@1.1.3 requires this version. Remove once no longer
+;; needed.
+(define-public fluidsynth-1
+ (package
+ (inherit fluidsynth)
+ (version "1.1.11")
+ (source (origin
+ (inherit (package-source fluidsynth))
+ (uri (git-reference
+ (url "https://github.com/FluidSynth/fluidsynth")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "fluidsynth" version))
+ (sha256
+ (base32
+ "0n75jq3xgq46hfmjkaaxz3gic77shs4fzajq40c8gk043i84xbdh"))))))
+
(define-public faad2
(package
(name "faad2")