summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-01-05 16:09:27 -0600
committerLudovic Courtès <ludo@gnu.org>2016-01-12 21:07:53 +0100
commitc91d3fb7f4f754b56b540d8556d6a3ce6085ef37 (patch)
tree89c7d1ff32dcf730de4c26033b8ea1786395129e /gnu/packages/audio.scm
parent3abe8136fddf5bed75219bcb8a552004f078560a (diff)
gnu: boost: Update to 1.60.0.
* gnu/packages/boost.scm (boost): Update to 1.60.0. [source]: Remove patch. * gnu/packages/patches/boost-mips-avoid-m32.patch: Delete patch * gnu-system.am (dist_patch_DATA): Remove patch. Also fix dependent packages: * gnu/packages/patches/csound-header-ordering.patch: New patch. * gnu/packages/audio.scm (csound)[source]: Use it. [arguments]: Add 'set-flags phase. * gnu/packages/patches/libcmis-fix-test-onedrive.patch: New patch. * gnu/packages/libreoffice.scm (libcmis)[source]: Use it. (libreoffice)[arguments]: Add LDFLAGS to #:configure-flags. (librevenge)[inputs]: Move boost from here... [propogated-inputs]: to here. [arguments]: Add LDFLAGS to #:configure-flags. * gnu/packages/patches/openimageio-boost-1.60.patch: New patch. * gnu/packages/graphics.scm (openimageio): Use it. * gnu-system.am (dist_patch_DATA): Add patches.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index ebae5d57d9..3cc5cebc2c 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -320,7 +320,8 @@ tools (analyzer, mono/stereo tools, crossovers).")
version "/Csound" version ".tar.gz"))
(sha256
(base32
- "0a1sni6lr7qpwywpggbkp0ia3h9bwwgf9i87gsag8ra2h30v82hd"))))
+ "0a1sni6lr7qpwywpggbkp0ia3h9bwwgf9i87gsag8ra2h30v82hd"))
+ (patches (list (search-patch "csound-header-ordering.patch")))))
(build-system cmake-build-system)
(arguments
;; Work around this error on x86_64 with libc 2.22+:
@@ -1081,7 +1082,16 @@ software.")
#:configure-flags
(list (string-append "--boost-includes="
(assoc-ref %build-inputs "boost")
- "/include"))))
+ "/include"))
+ #:phases (modify-phases %standard-phases
+ (add-before
+ 'configure 'set-flags
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; See e.g. https://github.com/lvtk/lvtk/issues/21
+ (setenv "LDFLAGS"
+ (string-append
+ "-L" (assoc-ref inputs "boost") "/lib "
+ "-lboost_system")))))))
(inputs
`(("boost" ,boost)
("lv2" ,lv2)))