summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-26 23:53:18 +0100
committerMarius Bakke <marius@gnu.org>2022-11-27 21:19:49 +0100
commitae64c4ac89c18a44f0240f403b4c290e31a62461 (patch)
treef12731f3590591993f9281e5f0b7fec0a84989f8 /gnu/packages/audio.scm
parentec10258c34c454295411be7dacf44d4ec5b9c152 (diff)
gnu: audacity: Update to 3.2.1.
* gnu/packages/audio.scm (audacity): Update to 3.2.1. [source]: Switch to GIT-FETCH. [inputs]: Remove LIBMAD. Add MPG123 and WAVPACK. [arguments]: Add configure flag to prevent spurious dependency. Adjust fix-cmake-rpath phase. Delete obsolete phases. * gnu/packages/patches/audacity-ffmpeg-fallback.patch: Adjust for 3.2.1.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm49
1 files changed, 28 insertions, 21 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 086e838f12..4df5fa29bc 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2018, 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
-;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2019, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
@@ -849,19 +849,26 @@ engineers, musicians, soundtrack editors and composers.")
(define-public audacity
(package
(name "audacity")
- (version "3.1.3")
+ (version "3.2.1")
(source
(origin
;; If built from the release tag, Audacity will describe itself
;; as an "Alpha test version" and suggest to users that they use
;; the "latest stable released version".
- (method url-fetch)
- (uri (string-append "https://github.com/audacity/audacity/releases/download/"
- "Audacity-" version "/audacity-" version
- "-source.tar.gz"))
+ ;; XXX: For 3.2.1 we rebelliously use a git tag anyway because the only
+ ;; "processed" download is a .zip containing a .tar.gz which does not
+ ;; fare well with the patch and snippet machinery:
+ ;; https://github.com/audacity/audacity/issues/3811
+ ;; TODO: Find a way to control the "alpha" status even when using git
+ ;; so we're not reliant on preprocessed source code.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/audacity/audacity")
+ (commit (string-append "Audacity-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "189agx11361k9j958s6q5bngnnfx0rwaf0dwbjxy6fwvsb1wv3px"))
+ "00mal30jxbcacs1ka4yb5s8xq81zm7mv3y8l5hvg77abkyvfvdzf"))
(patches (search-patches "audacity-ffmpeg-fallback.patch"))
(modules '((guix build utils)))
(snippet
@@ -896,9 +903,9 @@ engineers, musicians, soundtrack editors and composers.")
ffmpeg
libid3tag
libjpeg-turbo
- libmad
;;("libsbsms" ,libsbsms) ;bundled version is modified
libsndfile
+ mpg123
soundtouch
soxr ;replaces libsamplerate
sqlite
@@ -909,7 +916,8 @@ engineers, musicians, soundtrack editors and composers.")
lilv ;for lv2
suil ;for lv2
portaudio
- portmidi))
+ portmidi
+ wavpack))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -923,6 +931,9 @@ engineers, musicians, soundtrack editors and composers.")
(list
"-Daudacity_conan_enabled=off"
"-Daudacity_lib_preference=system"
+ ;; Disable support for VST 3 SDK, which is not yet in Guix (and has
+ ;; a dubious licensing agreement despite GPL code).
+ "-Daudacity_has_vst3=off"
;; TODO: enable this flag once we've packaged all dependencies
;; "-Daudacity_obey_system_dependencies=on"
;; disable crash reports, updates, ..., anything that phones home
@@ -944,24 +955,20 @@ engineers, musicians, soundtrack editors and composers.")
"CMAKE_BUILD_WITH_INSTALL_RPATH TRUE")
(("CMAKE_INSTALL_RPATH_USE_LINK_PATH [A-Z]*")
"CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE"))
+ (substitute* "libraries/image-compiler/CMakeLists.txt"
+ (("PROPERTIES")
+ ;; This scripts needs to run during build, make sure it finds
+ ;; the required libraries.
+ "PROPERTIES BUILD_WITH_INSTALL_RPATH FALSE"))
(substitute* "src/CMakeLists.txt"
+ ;; Despite the name, this script breaks rpath. Don't run it.
+ (("install.*linux/fix_rpath\\.cmake.*")
+ "")
(("-Wl,--disable-new-dtags") "-Wl,--enable-new-dtags"))))
- (add-after 'unpack 'comment-out-revision-ident
- (lambda _
- (substitute* "src/CMakeLists.txt"
- (("file\\( TOUCH \".*RevisionIdent\\.h\" \\)" directive)
- (string-append "# " directive)))
- (substitute* "src/AboutDialog.cpp"
- (("(.*RevisionIdent\\.h.*)" include-line)
- (string-append "// " include-line)))))
(add-after 'unpack 'use-upstream-headers
(lambda* (#:key inputs #:allow-other-keys)
(substitute* '("libraries/lib-files/FileNames.cpp")
(("\"/usr/include/linux/magic.h\"") "<linux/magic.h>"))))
- (add-after 'install 'delete-gratuitous-script
- (lambda* (#:key outputs #:allow-other-keys)
- (delete-file (string-append (assoc-ref outputs "out")
- "/audacity"))))
(add-after 'wrap-program 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))
;; The test suite is not "well exercised" according to the developers,