summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-12-28 01:02:47 +0100
committerMarius Bakke <marius@gnu.org>2022-12-28 01:02:47 +0100
commitec0fbb471dfc6f72796da9ebafbb0630daa91267 (patch)
tree3b42f3d0a6470d85fbb8421179634bb278883e4e /gnu/packages/audio.scm
parentf5ef7d34e4deecb80aff585c108b0a2ab1f33ce4 (diff)
parent0cb8f7125b19264b01962c1249c3df4c5ce85aa9 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm33
1 files changed, 15 insertions, 18 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 875d905ac6..78bd0e1446 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -603,7 +603,11 @@ Filter) modules follow the convention of 1V / Octave.")
"--enable-samplerate"
"--enable-avcodec")))
(inputs
- (list jack-1 libsndfile libsamplerate fftwf ffmpeg)) ; for libavcodec
+ (list jack-1
+ libsndfile
+ libsamplerate
+ ffmpeg-4 ;for libavcodec
+ fftwf))
(native-inputs
(list pkg-config))
(home-page "https://aubio.org/")
@@ -849,26 +853,16 @@ engineers, musicians, soundtrack editors and composers.")
(define-public audacity
(package
(name "audacity")
- (version "3.2.1")
+ (version "3.2.2")
(source
(origin
- ;; If built from the release tag, Audacity will describe itself
- ;; as an "Alpha test version" and suggest to users that they use
- ;; the "latest stable released version".
- ;; XXX: For 3.2.1 we rebelliously use a git tag anyway because the only
- ;; "processed" download is a .zip containing a .tar.gz which does not
- ;; fare well with the patch and snippet machinery:
- ;; https://github.com/audacity/audacity/issues/3811
- ;; TODO: Find a way to control the "alpha" status even when using git
- ;; so we're not reliant on preprocessed source code.
(method git-fetch)
(uri (git-reference
(url "https://github.com/audacity/audacity")
(commit (string-append "Audacity-" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "00mal30jxbcacs1ka4yb5s8xq81zm7mv3y8l5hvg77abkyvfvdzf"))
+ (base32 "1akp9marc4y2g9mwwgfnl43q0gbb2dv7vhsnybh8wdn8ql30hfdw"))
(patches (search-patches "audacity-ffmpeg-fallback.patch"))
(modules '((guix build utils)))
(snippet
@@ -936,7 +930,11 @@ engineers, musicians, soundtrack editors and composers.")
;; TODO: enable this flag once we've packaged all dependencies
;; "-Daudacity_obey_system_dependencies=on"
;; disable crash reports, updates, ..., anything that phones home
- "-Daudacity_has_networking=off")
+ "-Daudacity_has_networking=off"
+ ;; When building from Git — even from a release tag — this is undefined,
+ ;; and Audacity assumes that is is an ‘alpha’ version and includes debug
+ ;; symbols and extra code. Force level 2, ‘release’.
+ "-DAUDACITY_BUILD_LEVEL=2")
#:imported-modules ((guix build glib-or-gtk-build-system)
,@%cmake-build-system-modules)
#:modules
@@ -4442,7 +4440,7 @@ simplified, although really accurate, measuring tools.")
,home-page))
#t))))
(build-system gnu-build-system)
- (inputs (list ffmpeg sox))
+ (inputs (list ffmpeg-4 sox))
(synopsis "Tool to adjust loudness of media files")
(description
"BS1770GAIN is a loudness scanner compliant with ITU-R BS.1770 and its
@@ -5061,7 +5059,7 @@ stream to one or more IceCast and/or ShoutCast servers.")
(define-public libltc
(package
(name "libltc")
- (version "1.3.1")
+ (version "1.3.2")
(source
(origin
(method url-fetch)
@@ -5069,8 +5067,7 @@ stream to one or more IceCast and/or ShoutCast servers.")
(string-append "https://github.com/x42/libltc/releases/download/v"
version "/libltc-" version ".tar.gz"))
(sha256
- (base32
- "173h9dgmain3nyrwk6q2d7yl4fnh4vacag4s2p01n5b7nyrkxrjh"))))
+ (base32 "0j8j7cnw02arh8122d13bwkps1c0mi2xqq55gyi2bs91dk6l4v8a"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f)) ;tests fail otherwise