summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-27 22:35:33 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-27 22:35:33 +0100
commit168030ea0c5456157f68f41357bc542114d1161f (patch)
tree00d92841cdb6e145ef7d150d1e5f1ade7de13103 /gnu/packages/autotools.scm
parent82fe08ed207a17c51370dc90e965c15ee9db9235 (diff)
gnu: autoconf-wrapper: Fix "guile" input.
* gnu/packages/autotools.scm (autoconf-wrapper): Remove `lambda' for "guile" input..
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 1f18ebc1ca..47355d622b 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -72,10 +72,9 @@ can use, in the form of M4 macro calls.")
(name (string-append (package-name autoconf) "-wrapper"))
(build-system trivial-build-system)
(inputs `(("guile"
- ,(lambda _
- ;; XXX: Kludge to hide the circular dependency.
- (module-ref (resolve-interface '(gnu packages guile))
- 'guile-2.0)))
+ ;; XXX: Kludge to hide the circular dependency.
+ ,(module-ref (resolve-interface '(gnu packages guile))
+ 'guile-2.0))
("autoconf" ,autoconf)
("bash" ,bash)))
(arguments