summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-10 23:05:28 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-10 23:05:28 +0200
commitde80b5045b8467c34a7d53a6b62628202595f089 (patch)
tree1e6267c34161e1bcf9cdd2791a211ad3eb03ce98 /gnu/packages/autotools.scm
parent5fbeb4e6e19856678fa78ee7878e90411d718598 (diff)
gnu: Use the 'patches' field of <origin>.
* gnu/packages/autotools.scm (libtool): Add 'patches' field to the origin. Remove 'inputs' field. * gnu/packages/base.scm (findutils, gnu-make, binutils, glibc): Likewise. * gnu/packages/m4.scm (m4): Likewise. * gnu/packages/perl.scm (perl): Likewise. * gnu/packages/readline.scm (readline): Likewise.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm52
1 files changed, 25 insertions, 27 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index ab0c7dcbdf..bcab4e37cd 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -216,7 +216,8 @@ simplifying the entire process for the developer.")
version ".tar.gz"))
(sha256
(base32
- "0649qfpzkswgcj9vqkkr9rn4nlcx80faxpyqscy2k1x9c94f93dk"))))
+ "0649qfpzkswgcj9vqkkr9rn4nlcx80faxpyqscy2k1x9c94f93dk"))
+ (patches (list (search-patch "libtool-skip-tests.patch")))))
(build-system gnu-build-system)
(native-inputs `(("m4" ,m4)
("perl" ,perl)))
@@ -228,33 +229,30 @@ simplifying the entire process for the developer.")
"out")) ; libltdl.so, ltdl.h, etc.
(arguments
- `(#:patches (list (assoc-ref %build-inputs "patch/skip-tests"))
- ,@(if (%current-target-system)
- '() ; no `check' phase when cross-building
- '(#:phases (alist-cons-before
- 'check 'pre-check
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Run the test suite in parallel, if possible.
- (let ((ncores
- (cond
- ((getenv "NIX_BUILD_CORES")
- =>
- (lambda (n)
- (if (zero? (string->number n))
- (number->string (current-processor-count))
- n)))
- (else "1"))))
- (setenv "TESTSUITEFLAGS"
- (string-append "-j" ncores)))
+ (if (%current-target-system)
+ '() ; no `check' phase when cross-building
+ '(#:phases (alist-cons-before
+ 'check 'pre-check
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Run the test suite in parallel, if possible.
+ (let ((ncores
+ (cond
+ ((getenv "NIX_BUILD_CORES")
+ =>
+ (lambda (n)
+ (if (zero? (string->number n))
+ (number->string (current-processor-count))
+ n)))
+ (else "1"))))
+ (setenv "TESTSUITEFLAGS"
+ (string-append "-j" ncores)))
- ;; Path references to /bin/sh.
- (let ((bash (assoc-ref inputs "bash")))
- (substitute* "tests/testsuite"
- (("/bin/sh")
- (string-append bash "/bin/bash")))))
- %standard-phases)))))
- (inputs `(("patch/skip-tests"
- ,(search-patch "libtool-skip-tests.patch"))))
+ ;; Path references to /bin/sh.
+ (let ((bash (assoc-ref inputs "bash")))
+ (substitute* "tests/testsuite"
+ (("/bin/sh")
+ (string-append bash "/bin/bash")))))
+ %standard-phases))))
(synopsis "Generic shared library support tools")
(description
"Libtool is a script to help in the creation of shared libraries. By