summaryrefslogtreecommitdiff
path: root/gnu/packages/aux-files/python/sanity-check.py
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 21:01:34 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 21:01:34 -0400
commit3c8a4d64ffb9fe80ffbb32981bae72b0e690b0fa (patch)
treedbea023d45c10ad49a2be9360d42a8070770bfcd /gnu/packages/aux-files/python/sanity-check.py
parent20707a06d27f47d7034519b79175ee21c5546fcb (diff)
maint: Merge sanity-check-next.py into sanity-check.py.
* gnu/packages/aux-files/python/sanity-check-next.py: Rename to... * gnu/packages/aux-files/python/sanity-check.py: ... this. * guix/build-system/pyproject.scm (sanity-check.py): Adjust file name. * Makefile.am (AUX_FILES): De-register sanity-check-next.py.
Diffstat (limited to 'gnu/packages/aux-files/python/sanity-check.py')
-rw-r--r--gnu/packages/aux-files/python/sanity-check.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/aux-files/python/sanity-check.py b/gnu/packages/aux-files/python/sanity-check.py
index 182133bb3d..9c39709e18 100644
--- a/gnu/packages/aux-files/python/sanity-check.py
+++ b/gnu/packages/aux-files/python/sanity-check.py
@@ -1,6 +1,6 @@
# -*- coding: utf-8 -*-
# GNU Guix --- Functional package management for GNU
-# Copyright © 2021 Lars-Dominik Braun <lars@6xq.net>
+# Copyright © 2021, 2022 Lars-Dominik Braun <lars@6xq.net>
#
# This file is part of GNU Guix.
#
@@ -19,9 +19,13 @@
from __future__ import print_function # Python 2 support.
import importlib
-import pkg_resources
import sys
import traceback
+try:
+ import pkg_resources
+except ImportError:
+ print('Warning: Skipping, because python-setuptools are not available.')
+ sys.exit(0)
try:
from importlib.machinery import PathFinder