summaryrefslogtreecommitdiff
path: root/gnu/packages/aux-files
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-03-02 10:37:28 +0000
committerChristopher Baines <mail@cbaines.net>2023-03-02 10:55:08 +0000
commit7df09ee0ab3e7962ef27859ce87e06a323059284 (patch)
treed81334f742ddcb9a1ee63961ca6410922980af1c /gnu/packages/aux-files
parent2ac51ec99b58b50c08ba719a8c7e9dba0330b065 (diff)
parentaf95f2d8f98eb2c8c64954bb2fd0b70838899174 (diff)
Merge remote-tracking branch 'savannah/master' into core-updates
Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm
Diffstat (limited to 'gnu/packages/aux-files')
-rw-r--r--gnu/packages/aux-files/emacs/guix-emacs.el7
-rw-r--r--gnu/packages/aux-files/linux-libre/4.14-i686.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/4.14-x86_64.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/4.19-i686.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/4.19-x86_64.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/5.10-arm.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/5.10-arm64.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/5.10-i686.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/5.10-x86_64.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/5.15-arm.conf4
-rw-r--r--gnu/packages/aux-files/linux-libre/5.15-arm64.conf4
-rw-r--r--gnu/packages/aux-files/linux-libre/5.15-i686.conf4
-rw-r--r--gnu/packages/aux-files/linux-libre/5.15-x86_64.conf4
-rw-r--r--gnu/packages/aux-files/linux-libre/5.4-arm.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/5.4-arm64.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/5.4-i686.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/5.4-x86_64.conf2
-rw-r--r--gnu/packages/aux-files/linux-libre/6.1-arm.conf4
-rw-r--r--gnu/packages/aux-files/linux-libre/6.1-arm64.conf4
-rw-r--r--gnu/packages/aux-files/linux-libre/6.1-i686.conf4
-rw-r--r--gnu/packages/aux-files/linux-libre/6.1-x86_64.conf4
21 files changed, 35 insertions, 28 deletions
diff --git a/gnu/packages/aux-files/emacs/guix-emacs.el b/gnu/packages/aux-files/emacs/guix-emacs.el
index 56dbcb8d67..708093267d 100644
--- a/gnu/packages/aux-files/emacs/guix-emacs.el
+++ b/gnu/packages/aux-files/emacs/guix-emacs.el
@@ -76,6 +76,13 @@ The files in the list do not have extensions (.el, .elc)."
(when (file-directory-p pkg-dir)
(package-load-descriptor pkg-dir)))))))))))
+;; If emacs built with tree-sitter, read the value of the environment variable
+;; to make tree-sitter grammars available in emacs out-of-the-box.
+(with-eval-after-load 'treesit
+ (when-let ((grammar-path (getenv "TREE_SITTER_GRAMMAR_PATH")))
+ (mapcar (lambda (x) (add-to-list 'treesit-extra-load-path x))
+ (split-string grammar-path ":"))))
+
(provide 'guix-emacs)
;;; guix-emacs.el ends here
diff --git a/gnu/packages/aux-files/linux-libre/4.14-i686.conf b/gnu/packages/aux-files/linux-libre/4.14-i686.conf
index 16a7817115..6ac3782c02 100644
--- a/gnu/packages/aux-files/linux-libre/4.14-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/4.14-i686.conf
@@ -1645,7 +1645,7 @@ CONFIG_NET_FLOW_LIMIT=y
#
CONFIG_NET_PKTGEN=m
CONFIG_NET_TCPPROBE=m
-# CONFIG_NET_DROP_MONITOR is not set
+CONFIG_NET_DROP_MONITOR=m
CONFIG_HAMRADIO=y
#
diff --git a/gnu/packages/aux-files/linux-libre/4.14-x86_64.conf b/gnu/packages/aux-files/linux-libre/4.14-x86_64.conf
index 3953ee9104..8171e5ec5e 100644
--- a/gnu/packages/aux-files/linux-libre/4.14-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/4.14-x86_64.conf
@@ -1639,7 +1639,7 @@ CONFIG_NET_FLOW_LIMIT=y
#
CONFIG_NET_PKTGEN=m
CONFIG_NET_TCPPROBE=m
-# CONFIG_NET_DROP_MONITOR is not set
+CONFIG_NET_DROP_MONITOR=m
CONFIG_HAMRADIO=y
#
diff --git a/gnu/packages/aux-files/linux-libre/4.19-i686.conf b/gnu/packages/aux-files/linux-libre/4.19-i686.conf
index 0e6637325d..2ab9d081d3 100644
--- a/gnu/packages/aux-files/linux-libre/4.19-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/4.19-i686.conf
@@ -1747,7 +1747,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-# CONFIG_NET_DROP_MONITOR is not set
+CONFIG_NET_DROP_MONITOR=m
CONFIG_HAMRADIO=y
#
diff --git a/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf b/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf
index 24148dcf6f..81bdb00117 100644
--- a/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf
@@ -1753,7 +1753,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-# CONFIG_NET_DROP_MONITOR is not set
+CONFIG_NET_DROP_MONITOR=m
CONFIG_HAMRADIO=y
#
diff --git a/gnu/packages/aux-files/linux-libre/5.10-arm.conf b/gnu/packages/aux-files/linux-libre/5.10-arm.conf
index c4f714f5e1..f544be58f7 100644
--- a/gnu/packages/aux-files/linux-libre/5.10-arm.conf
+++ b/gnu/packages/aux-files/linux-libre/5.10-arm.conf
@@ -1745,7 +1745,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-CONFIG_NET_DROP_MONITOR=y
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/5.10-arm64.conf b/gnu/packages/aux-files/linux-libre/5.10-arm64.conf
index 046c310d85..fc8a892872 100644
--- a/gnu/packages/aux-files/linux-libre/5.10-arm64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.10-arm64.conf
@@ -1758,7 +1758,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-CONFIG_NET_DROP_MONITOR=y
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/5.10-i686.conf b/gnu/packages/aux-files/linux-libre/5.10-i686.conf
index 23b159057d..be02316b2c 100644
--- a/gnu/packages/aux-files/linux-libre/5.10-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/5.10-i686.conf
@@ -1756,7 +1756,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-# CONFIG_NET_DROP_MONITOR is not set
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
index 2760c71f62..b801d13e83 100644
--- a/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
@@ -1784,7 +1784,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-# CONFIG_NET_DROP_MONITOR is not set
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/5.15-arm.conf b/gnu/packages/aux-files/linux-libre/5.15-arm.conf
index a45530711e..3915ac6d53 100644
--- a/gnu/packages/aux-files/linux-libre/5.15-arm.conf
+++ b/gnu/packages/aux-files/linux-libre/5.15-arm.conf
@@ -101,7 +101,7 @@ CONFIG_HAVE_EBPF_JIT=y
CONFIG_BPF_SYSCALL=y
CONFIG_BPF_JIT=y
# CONFIG_BPF_JIT_ALWAYS_ON is not set
-# CONFIG_BPF_UNPRIV_DEFAULT_OFF is not set
+CONFIG_BPF_UNPRIV_DEFAULT_OFF=y
# CONFIG_BPF_PRELOAD is not set
CONFIG_BPF_LSM=y
# end of BPF subsystem
@@ -1736,7 +1736,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-CONFIG_NET_DROP_MONITOR=y
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/5.15-arm64.conf b/gnu/packages/aux-files/linux-libre/5.15-arm64.conf
index 3a3d144330..60069fe4c9 100644
--- a/gnu/packages/aux-files/linux-libre/5.15-arm64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.15-arm64.conf
@@ -96,7 +96,7 @@ CONFIG_BPF_SYSCALL=y
CONFIG_BPF_JIT=y
# CONFIG_BPF_JIT_ALWAYS_ON is not set
CONFIG_BPF_JIT_DEFAULT_ON=y
-# CONFIG_BPF_UNPRIV_DEFAULT_OFF is not set
+CONFIG_BPF_UNPRIV_DEFAULT_OFF=y
# CONFIG_BPF_PRELOAD is not set
CONFIG_BPF_LSM=y
# end of BPF subsystem
@@ -1756,7 +1756,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-CONFIG_NET_DROP_MONITOR=y
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/5.15-i686.conf b/gnu/packages/aux-files/linux-libre/5.15-i686.conf
index ab2008f3e5..5808a9977d 100644
--- a/gnu/packages/aux-files/linux-libre/5.15-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/5.15-i686.conf
@@ -108,7 +108,7 @@ CONFIG_HAVE_EBPF_JIT=y
#
CONFIG_BPF_SYSCALL=y
# CONFIG_BPF_JIT is not set
-# CONFIG_BPF_UNPRIV_DEFAULT_OFF is not set
+CONFIG_BPF_UNPRIV_DEFAULT_OFF=y
# CONFIG_BPF_PRELOAD is not set
# end of BPF subsystem
@@ -1765,7 +1765,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-# CONFIG_NET_DROP_MONITOR is not set
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/5.15-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.15-x86_64.conf
index 8fbb48bcb6..22f905a642 100644
--- a/gnu/packages/aux-files/linux-libre/5.15-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.15-x86_64.conf
@@ -112,7 +112,7 @@ CONFIG_ARCH_WANT_DEFAULT_BPF_JIT=y
#
CONFIG_BPF_SYSCALL=y
# CONFIG_BPF_JIT is not set
-# CONFIG_BPF_UNPRIV_DEFAULT_OFF is not set
+CONFIG_BPF_UNPRIV_DEFAULT_OFF=y
# CONFIG_BPF_PRELOAD is not set
# end of BPF subsystem
@@ -1802,7 +1802,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-# CONFIG_NET_DROP_MONITOR is not set
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/5.4-arm.conf b/gnu/packages/aux-files/linux-libre/5.4-arm.conf
index e985f1ded8..d51ff92fc0 100644
--- a/gnu/packages/aux-files/linux-libre/5.4-arm.conf
+++ b/gnu/packages/aux-files/linux-libre/5.4-arm.conf
@@ -1713,7 +1713,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-CONFIG_NET_DROP_MONITOR=y
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/5.4-arm64.conf b/gnu/packages/aux-files/linux-libre/5.4-arm64.conf
index 3b05083301..28cc5127a0 100644
--- a/gnu/packages/aux-files/linux-libre/5.4-arm64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.4-arm64.conf
@@ -1690,7 +1690,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-CONFIG_NET_DROP_MONITOR=y
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/5.4-i686.conf b/gnu/packages/aux-files/linux-libre/5.4-i686.conf
index 83019bc0c7..302df38cfc 100644
--- a/gnu/packages/aux-files/linux-libre/5.4-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/5.4-i686.conf
@@ -1723,7 +1723,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-# CONFIG_NET_DROP_MONITOR is not set
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf
index 7325ac21fc..dde91cd01c 100644
--- a/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf
@@ -1736,7 +1736,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-# CONFIG_NET_DROP_MONITOR is not set
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/6.1-arm.conf b/gnu/packages/aux-files/linux-libre/6.1-arm.conf
index d0e1c9ad08..46eb0c07e1 100644
--- a/gnu/packages/aux-files/linux-libre/6.1-arm.conf
+++ b/gnu/packages/aux-files/linux-libre/6.1-arm.conf
@@ -103,7 +103,7 @@ CONFIG_HAVE_EBPF_JIT=y
CONFIG_BPF_SYSCALL=y
CONFIG_BPF_JIT=y
# CONFIG_BPF_JIT_ALWAYS_ON is not set
-# CONFIG_BPF_UNPRIV_DEFAULT_OFF is not set
+CONFIG_BPF_UNPRIV_DEFAULT_OFF=y
# CONFIG_BPF_PRELOAD is not set
CONFIG_BPF_LSM=y
# end of BPF subsystem
@@ -1757,7 +1757,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-CONFIG_NET_DROP_MONITOR=y
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/6.1-arm64.conf b/gnu/packages/aux-files/linux-libre/6.1-arm64.conf
index b5654dcd8e..507e38c9ad 100644
--- a/gnu/packages/aux-files/linux-libre/6.1-arm64.conf
+++ b/gnu/packages/aux-files/linux-libre/6.1-arm64.conf
@@ -112,7 +112,7 @@ CONFIG_BPF_SYSCALL=y
CONFIG_BPF_JIT=y
# CONFIG_BPF_JIT_ALWAYS_ON is not set
CONFIG_BPF_JIT_DEFAULT_ON=y
-# CONFIG_BPF_UNPRIV_DEFAULT_OFF is not set
+CONFIG_BPF_UNPRIV_DEFAULT_OFF=y
# CONFIG_BPF_PRELOAD is not set
CONFIG_BPF_LSM=y
# end of BPF subsystem
@@ -1772,7 +1772,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-CONFIG_NET_DROP_MONITOR=y
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/6.1-i686.conf b/gnu/packages/aux-files/linux-libre/6.1-i686.conf
index b91ff79b72..58f84b901a 100644
--- a/gnu/packages/aux-files/linux-libre/6.1-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/6.1-i686.conf
@@ -111,7 +111,7 @@ CONFIG_HAVE_EBPF_JIT=y
#
CONFIG_BPF_SYSCALL=y
# CONFIG_BPF_JIT is not set
-# CONFIG_BPF_UNPRIV_DEFAULT_OFF is not set
+CONFIG_BPF_UNPRIV_DEFAULT_OFF=y
# CONFIG_BPF_PRELOAD is not set
# end of BPF subsystem
@@ -1810,7 +1810,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-# CONFIG_NET_DROP_MONITOR is not set
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options
diff --git a/gnu/packages/aux-files/linux-libre/6.1-x86_64.conf b/gnu/packages/aux-files/linux-libre/6.1-x86_64.conf
index 68187506f1..31e5744ff3 100644
--- a/gnu/packages/aux-files/linux-libre/6.1-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/6.1-x86_64.conf
@@ -116,7 +116,7 @@ CONFIG_ARCH_WANT_DEFAULT_BPF_JIT=y
#
CONFIG_BPF_SYSCALL=y
# CONFIG_BPF_JIT is not set
-# CONFIG_BPF_UNPRIV_DEFAULT_OFF is not set
+CONFIG_BPF_UNPRIV_DEFAULT_OFF=y
# CONFIG_BPF_PRELOAD is not set
# end of BPF subsystem
@@ -1871,7 +1871,7 @@ CONFIG_NET_FLOW_LIMIT=y
# Network testing
#
CONFIG_NET_PKTGEN=m
-# CONFIG_NET_DROP_MONITOR is not set
+CONFIG_NET_DROP_MONITOR=m
# end of Network testing
# end of Networking options