summaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
authorSergey Trofimov <sarg@sarg.org.ru>2023-03-22 09:11:36 +0100
committerLeo Famulari <leo@famulari.name>2023-03-22 12:51:17 -0400
commitafb1373fce0aa169fea6595cfba7a00d63fd4e8f (patch)
treef73a15f775946b4b379cead87651fa4f41ed2814 /gnu/packages/backup.scm
parent91f92f32d5a9317dd333d570b54c2ba34c9c14a9 (diff)
gnu: borgmatic: Update to 1.7.9.
* gnu/packages/backup.scm (borgmatic): Update to 1.7.9. [arguments]: Set absolute store paths in the custom 'configure' phase. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index cf47ac9c80..97a4c36696 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -1255,13 +1255,13 @@ compression parameters used by Gzip.")
(define-public borgmatic
(package
(name "borgmatic")
- (version "1.5.22")
+ (version "1.7.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "borgmatic" version))
(sha256
- (base32 "0pvqlj17vp81i7saxqh5hsaxqz29ldrjd7bcssh4g1h0ikmnaf2r"))))
+ (base32 "1scfh90qgv8xhafnnpl3pa9d8m4rg9xgvf21yybvmsnm5v1k2x5z"))))
(build-system python-build-system)
(arguments
(list #:phases
@@ -1270,10 +1270,15 @@ compression parameters used by Gzip.")
(lambda* (#:key inputs #:allow-other-keys)
;; Set absolute store path to borg.
(substitute* "borgmatic/commands/borgmatic.py"
- (("location\\.get\\('local_path', 'borg'\\)")
- (string-append "location.get('local_path', '"
+ (("\\.get\\('local_path', 'borg'\\)")
+ (string-append ".get('local_path', '"
(search-input-file inputs "bin/borg")
- "')")))))
+ "')")))
+ (substitute* "tests/unit/commands/test_borgmatic.py"
+ (("(module.get_local_path.+ == )'borg'" all start)
+ (string-append start "'"
+ (search-input-file inputs "bin/borg")
+ "'")))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?