summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-11-23 19:31:12 +0100
committerLudovic Courtès <ludo@gnu.org>2022-11-23 19:34:42 +0100
commit02a4e54250e81664a797466edba46b017ae1a7b0 (patch)
treee707f4282435671b85a98459a53c1fc8da3d8eae /gnu/packages/base.scm
parent2b151eb2868f28c098328019e24cb1d05cd19d2b (diff)
gnu: grep: Skip 'triple-backref' test.
* gnu/packages/base.scm (grep)[arguments]: Add 'skip-triple-backref-test' phase for GNU/Hurd.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index bf6435585e..36b27a4e25 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -130,7 +130,19 @@ command-line arguments, multiple languages, and so on.")
(substitute* (list (string-append bin "/egrep")
(string-append bin "/fgrep"))
(("^exec grep")
- (string-append "exec " bin "/grep")))))))
+ (string-append "exec " bin "/grep"))))))
+ ,@(if (hurd-target?)
+ '((add-before 'check 'skip-triple-backref-test
+ (lambda _
+ ;; This test is marked as malfunctioning on glibc systems
+ ;; due to
+ ;; <https://sourceware.org/bugzilla/show_bug.cgi?id=11053>
+ ;; and it triggers a segfault with glibc 2.33 on GNU/Hurd.
+ ;; Skip it.
+ (substitute* "tests/triple-backref"
+ (("^warn_" all)
+ (string-append "exit 77\n" all))))))
+ '()))
#:make-flags ,(if (hurd-target?)
''("XFAIL_TESTS=test-perror2 equiv-classes") ;XXX
''())))