summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-11-28 12:26:32 +0100
committerLudovic Courtès <ludo@gnu.org>2022-11-28 12:26:32 +0100
commit459e4f2a4f2b16daded2aaba20edf3fffa4095f3 (patch)
treed1e2ada4dcfde3d3b4119087550c26856b42dbcf /gnu/packages/base.scm
parenta3264f31df9774ea514e18ed8e7b6bcb44061edc (diff)
parente6bffa99b19fe01067937a4930f1b107bd0ac398 (diff)
Merge commit 'master' into version-1.4.0
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index bf6435585e..36b27a4e25 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -130,7 +130,19 @@ command-line arguments, multiple languages, and so on.")
(substitute* (list (string-append bin "/egrep")
(string-append bin "/fgrep"))
(("^exec grep")
- (string-append "exec " bin "/grep")))))))
+ (string-append "exec " bin "/grep"))))))
+ ,@(if (hurd-target?)
+ '((add-before 'check 'skip-triple-backref-test
+ (lambda _
+ ;; This test is marked as malfunctioning on glibc systems
+ ;; due to
+ ;; <https://sourceware.org/bugzilla/show_bug.cgi?id=11053>
+ ;; and it triggers a segfault with glibc 2.33 on GNU/Hurd.
+ ;; Skip it.
+ (substitute* "tests/triple-backref"
+ (("^warn_" all)
+ (string-append "exit 77\n" all))))))
+ '()))
#:make-flags ,(if (hurd-target?)
''("XFAIL_TESTS=test-perror2 equiv-classes") ;XXX
''())))