summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-11-07 00:44:56 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-07 00:44:56 +0100
commit19ac2ba858ebc46db96364809ebfc129be9e4ccf (patch)
treed129f4cdc6a9ac2d70f23132c26d450dba0f9f9d /gnu/packages/base.scm
parent8b6ad165d1fa479e5da2938d099dba356186e07c (diff)
gnu: glibc: Add version 2.23.
* gnu/packages/base.scm (glibc-2.23): New variable.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 77ba2c7454..1c01874bb0 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -743,9 +743,22 @@ GLIBC/HURD for a Hurd host"
(define-syntax glibc
(identifier-syntax (glibc-for-target)))
+;; Below are old libc versions, which we use mostly to build locale data in
+;; the old format (which the new libc cannot cope with.)
+
+(define-public glibc-2.23
+ (package
+ (inherit glibc)
+ (version "2.23")
+ (source (origin
+ (inherit (package-source glibc))
+ (uri (string-append "mirror://gnu/glibc/glibc-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1s8krs3y2n6pzav7ic59dz41alqalphv7vww4138ag30wh0fpvwl"))))))
+
(define-public glibc-2.22
- ;; The old libc, which we use mostly to build locale data in the old format
- ;; (which the new libc can cope with.)
(package
(inherit glibc)
(version "2.22")
@@ -768,8 +781,6 @@ GLIBC/HURD for a Hurd host"
(("/bin/pwd") "pwd"))))))))))
(define-public glibc-2.21
- ;; The old libc, which we use mostly to build locale data in the old format
- ;; (which the new libc can cope with.)
(package
(inherit glibc-2.22)
(version "2.21")