summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-07-11 10:23:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-07-11 16:52:40 +0300
commit38e9373b0d668d9e8347e0d6adce218480d41661 (patch)
tree6a9cf1e8c865c49b45f2c8ef7695c2be4f59cf58 /gnu/packages/base.scm
parent4277313883c6cd21c2abc652e224e369b258f226 (diff)
gnu: glibc-2.21: Fix substitutes in glibc-2.21.
* gnu/packages/base.scm (glibc-2.21)[arguments]: Add back substitution for /bin/pwd which was removed in the update of glibc to 2.23.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 422424cbe8..ed1f84c470 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -732,7 +732,16 @@ GLIBC/HURD for a Hurd host"
(sha256
(base32
"1f135546j34s9bfkydmx2nhh9vwxlx60jldi80zmsnln6wj3dsxf"))
- (patches (search-patches "glibc-ldd-x86_64.patch"))))))
+ (patches (search-patches "glibc-ldd-x86_64.patch"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments glibc)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-before 'configure 'fix-pwd
+ (lambda _
+ ;; Use `pwd' instead of `/bin/pwd' for glibc-2.21
+ (substitute* "configure"
+ (("/bin/pwd") "pwd"))))))))))
(define-public glibc-locales
(package