summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-06 17:09:42 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-06 22:24:13 +0200
commit61516a1613efd0e12afc83922b005e5218b3624a (patch)
tree59ceefee6ac7d30db23515e07b5378799304e0dc /gnu/packages/base.scm
parent81cea47d4a4c0054beb234004b990d6f514d0514 (diff)
Revert "gnu: binutils: Update to 2.26."
This reverts commit 5d9356f0fe67e679e35b92b5020a4a7b850af81c. Binutils 2.26 and ld in particular reportedly has serious bugs. For us, ld from 'binutils-cross-boot0' fails when linking 'cc1plus' in the first stage.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 7bd2ba4121..2010bc0d57 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -346,14 +346,14 @@ change. GNU make offers many powerful extensions over the standard utility.")
(define-public binutils
(package
(name "binutils")
- (version "2.26")
+ (version "2.25.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/binutils/binutils-"
version ".tar.bz2"))
(sha256
(base32
- "1ngc2h3knhiw8s22l8y6afycfaxr5grviqy7mwvm4bsl14cf9b62"))
+ "08lzmhidzc16af1zbx34f8cy4z7mzrswpdbhrb8shy3xxpflmcdm"))
(patches (list (search-patch "binutils-ld-new-dtags.patch")
(search-patch "binutils-loongson-workaround.patch")))))
(build-system gnu-build-system)