summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-07-30 13:14:36 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-30 15:47:28 +0200
commitc2c54ebd9153fd4a9609a3c58fb689aa9b242640 (patch)
tree35b370f88f26e7b56b1bfa9e5d875a58082360d3 /gnu/packages/base.scm
parent716753cb9768dde6494b4bd2895f2186c31c0e34 (diff)
gnu: Add glibc 2.22.
* gnu/packages/base.scm (glibc-2.22): New variable. (glibc-2.21): Inherit from it; remove 'arguments' field.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm21
1 files changed, 18 insertions, 3 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index ed1f84c470..3135108ac8 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -719,19 +719,19 @@ GLIBC/HURD for a Hurd host"
(define-syntax glibc
(identifier-syntax (glibc-for-target)))
-(define-public glibc-2.21
+(define-public glibc-2.22
;; The old libc, which we use mostly to build locale data in the old format
;; (which the new libc can cope with.)
(package
(inherit glibc)
- (version "2.21")
+ (version "2.22")
(source (origin
(inherit (package-source glibc))
(uri (string-append "mirror://gnu/glibc/glibc-"
version ".tar.xz"))
(sha256
(base32
- "1f135546j34s9bfkydmx2nhh9vwxlx60jldi80zmsnln6wj3dsxf"))
+ "0j49682pm2nh4qbdw35bas82p1pgfnz4d2l7iwfyzvrvj0318wzb"))
(patches (search-patches "glibc-ldd-x86_64.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments glibc)
@@ -743,6 +743,21 @@ GLIBC/HURD for a Hurd host"
(substitute* "configure"
(("/bin/pwd") "pwd"))))))))))
+(define-public glibc-2.21
+ ;; The old libc, which we use mostly to build locale data in the old format
+ ;; (which the new libc can cope with.)
+ (package
+ (inherit glibc-2.22)
+ (version "2.21")
+ (source (origin
+ (inherit (package-source glibc))
+ (uri (string-append "mirror://gnu/glibc/glibc-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1f135546j34s9bfkydmx2nhh9vwxlx60jldi80zmsnln6wj3dsxf"))
+ (patches (search-patches "glibc-ldd-x86_64.patch"))))))
+
(define-public glibc-locales
(package
(inherit glibc)