summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-08-26 14:44:14 -0400
committerMark H Weaver <mhw@netris.org>2014-08-26 16:04:16 -0400
commitf5beb0caf31f227dbe3dd909ec318e84247a504a (patch)
treee835daf3c9b7b171a30dd15d3aa4ad51354f7aa6 /gnu/packages/base.scm
parent48abd130217bd1645fefc4ca1817862672c6d782 (diff)
gnu: glibc: Fix CVE-2014-5119.
* gnu/packages/patches/glibc-CVE-2014-5119.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/base.scm (glibc): Add the patch.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 30176cfddb..6f340172e0 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -384,7 +384,8 @@ library for working with executable and object formats is also included.")
(("use_ldconfig=yes")
"use_ldconfig=no")))
(modules '((guix build utils)))
- (patches (list (search-patch "glibc-ldd-x86_64.patch")))))
+ (patches (list (search-patch "glibc-CVE-2014-5119.patch")
+ (search-patch "glibc-ldd-x86_64.patch")))))
(build-system gnu-build-system)
;; Glibc's <limits.h> refers to <linux/limit.h>, for instance, so glibc