summaryrefslogtreecommitdiff
path: root/gnu/packages/bash.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-02-28 17:06:22 +0100
committerLudovic Courtès <ludo@gnu.org>2023-02-28 17:10:40 +0100
commit2aee6bb90c535df1451ba94db39e8f940dd1f297 (patch)
treeb7c5ad07a8b422f83af116770dcaecac86e7e3c4 /gnu/packages/bash.scm
parent61efecd33934ce6fd800c9a279691700d1f784ed (diff)
gnu: bash-static: Use gexps.
* gnu/packages/bash.scm (static-bash)[arguments]: Use gexps.
Diffstat (limited to 'gnu/packages/bash.scm')
-rw-r--r--gnu/packages/bash.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 3aefe03276..43f38303f7 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012-2017, 2019-2020, 2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2017, 2019-2020, 2022, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2018, 2019, 2022 Efraim Flashner <efraim@flashner.co.il>
@@ -270,15 +270,15 @@ without modification.")
(substitute-keyword-arguments
`(#:allowed-references ("out") ,@(package-arguments bash))
((#:phases phases)
- `(modify-phases ,phases
- (add-after 'strip 'remove-everything-but-the-binary
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (remove-store-references (string-append bin "/bash"))
- (delete-file (string-append bin "/bashbug"))
- (delete-file-recursively (string-append out "/share"))
- #t))))))))))
+ #~(modify-phases #$phases
+ (add-after 'strip 'remove-everything-but-the-binary
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (remove-store-references (string-append bin "/bash"))
+ (delete-file (string-append bin "/bashbug"))
+ (delete-file-recursively (string-append out "/share"))
+ #t))))))))))
(define-public bash-with-syslog
(package