summaryrefslogtreecommitdiff
path: root/gnu/packages/bdb.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-17 23:53:42 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-18 00:12:22 +0200
commit90a0048f5e1ac161fb7a32b361fe35564caabaf9 (patch)
tree51da46a58280d74c91a812a921fe7159159be57c /gnu/packages/bdb.scm
parent10afdf506166e028dfb48d56d1f3bff3155b90f8 (diff)
gnu: Add Linux iproute2.
* gnu/packages/bdb.scm (bdb): Add `--enable-compat185'. * gnu/packages/linux.scm (iproute): New variable.
Diffstat (limited to 'gnu/packages/bdb.scm')
-rw-r--r--gnu/packages/bdb.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/bdb.scm b/gnu/packages/bdb.scm
index 9a626b17d7..75a2b72b44 100644
--- a/gnu/packages/bdb.scm
+++ b/gnu/packages/bdb.scm
@@ -45,7 +45,11 @@
(system* "./dist/configure"
(string-append "--prefix=" out)
(string-append "CONFIG_SHELL=" (which "bash"))
- (string-append "SHELL=" (which "bash"))))))
+ (string-append "SHELL=" (which "bash"))
+
+ ;; The compatibility mode is needed by some packages,
+ ;; notably iproute2.
+ "--enable-compat185"))))
%standard-phases)))
(synopsis "db, the Berkeley database")
(description