summaryrefslogtreecommitdiff
path: root/gnu/packages/bdw-gc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-02-28 17:42:32 +0100
committerLudovic Courtès <ludo@gnu.org>2023-03-02 21:40:35 +0100
commit5222ed8dc364f13a36bca13c151856a3edab795a (patch)
treed4288270ee5f9e5764b3da76dd06f116f83d73ac /gnu/packages/bdw-gc.scm
parent7df09ee0ab3e7962ef27859ce87e06a323059284 (diff)
gnu: libgc: Update to 8.2.2 and remove '--disable-munmap'.
* gnu/packages/bdw-gc.scm (libgc): Update to 8.2.2. [arguments]: Remove "--disable-munmap" from #:configure-flags. * gnu/packages/guile.scm (guile-3.0)[source]: Leave 'test-out-of-memory' test untouched. (guile-next)[arguments]: Likewise, in 'skip-failing-tests' phase. (guile-for-guile-emacs)[arguments]: Likewise, in 'bootstrap' phase.
Diffstat (limited to 'gnu/packages/bdw-gc.scm')
-rw-r--r--gnu/packages/bdw-gc.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index db01d1a7e2..4b7099ffcd 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -34,7 +34,7 @@
(define-public libgc
(package
(name "libgc")
- (version "8.0.6")
+ (version "8.2.2")
(source (origin
(method url-fetch)
(uri (list (string-append "https://github.com/ivmai/bdwgc/releases"
@@ -44,7 +44,7 @@
"/gc-" version ".tar.gz")))
(sha256
(base32
- "04ga3c95w5az5sznzm73j19lvvfpf6k4sgkpjqsmjxpsr6mi8j9v"))))
+ "181ni2rn9qjbl4ilqdjrd1a4h8siv5bgmzqgg4595q32n2y0f0gk"))))
(build-system gnu-build-system)
(arguments
(list
@@ -53,9 +53,6 @@
;; Install gc_cpp.h et al.
"--enable-cplusplus"
- ;; Work around <https://github.com/ivmai/bdwgc/issues/353>.
- "--disable-munmap"
-
;; In GNU/Hurd systems during the 'check' phase,
;; there is a deadlock caused by the 'gctest' test.
;; To disable the error set "--disable-gcj-support"