summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-06 21:16:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-06 21:16:33 +0100
commit66e35ce63b346f5f13b2d48a76bc0da14637c58c (patch)
treea0cb0d94768822c2740a759e365ad021dc6d90f3 /gnu/packages/bioconductor.scm
parentbfb93b4889a2352f47df56dedf0a10cd2dfc441c (diff)
gnu: r-txdb-hsapiens-ucsc-hg19-knowngene: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-txdb-hsapiens-ucsc-hg19-knowngene): Move from here... * gnu/packages/bioconductor.scm (r-txdb-hsapiens-ucsc-hg19-knowngene): ...to here.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index f3ea87cdb1..316be1ca42 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -224,6 +224,38 @@ based on mapping using Entrez Gene identifiers.")
genomes and gene ID formats, largely based on the UCSC table browser.")
(license license:lgpl2.0+)))
+(define-public r-txdb-hsapiens-ucsc-hg19-knowngene
+ (package
+ (name "r-txdb-hsapiens-ucsc-hg19-knowngene")
+ (version "3.2.2")
+ (source (origin
+ (method url-fetch)
+ ;; We cannot use bioconductor-uri here because this tarball is
+ ;; located under "data/annotation/" instead of "bioc/".
+ (uri (string-append "https://bioconductor.org/packages/"
+ "release/data/annotation/src/contrib"
+ "/TxDb.Hsapiens.UCSC.hg19.knownGene_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1sajhcqqwazgz2lqbik7rd935i7kpnh08zxbp2ra10j72yqy4g86"))))
+ (properties
+ `((upstream-name . "TxDb.Hsapiens.UCSC.hg19.knownGene")))
+ (build-system r-build-system)
+ ;; As this package provides little more than a very large data file it
+ ;; doesn't make sense to build substitutes.
+ (arguments `(#:substitutable? #f))
+ (propagated-inputs
+ `(("r-genomicfeatures" ,r-genomicfeatures)))
+ (home-page
+ "https://bioconductor.org/packages/TxDb.Hsapiens.UCSC.hg19.knownGene/")
+ (synopsis "Annotation package for human genome in TxDb format")
+ (description
+ "This package provides an annotation database of Homo sapiens genome
+data. It is derived from the UCSC hg19 genome and based on the \"knownGene\"
+track. The database is exposed as a @code{TxDb} object.")
+ (license license:artistic2.0)))
+
(define-public r-txdb-mmusculus-ucsc-mm9-knowngene
(package
(name "r-txdb-mmusculus-ucsc-mm9-knowngene")