summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-18 15:18:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-18 15:19:46 +0100
commite6bc150b0c8a72da115ba3243031215137991761 (patch)
tree0f0b0e2365aa1e25cd74ebae5f61947069ef8a14 /gnu/packages/bioconductor.scm
parentc319b965e07b4a62247d7da5d17529369cf0d77e (diff)
gnu: Add r-cner.
* gnu/packages/bioconductor.scm (r-cner): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 8fe56c4a5b..38a34912ef 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8875,6 +8875,57 @@ variety of commonly used matrix types, including sparse and HDF5-backed
matrices.")
(license license:gpl3)))
+;; This package includes files that have been taken from kentutils. Some
+;; parts of kentutils are not released under a free license, but this package
+;; only uses files that are also found in the free parts of kentutils.
+(define-public r-cner
+ (package
+ (name "r-cner")
+ (version "1.26.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "CNEr" version))
+ (sha256
+ (base32 "0qy4pm23vyy23zwsjkf0mpf2c0p54nq26w9lq7j0ld4bx9l3jc6c"))))
+ (properties `((upstream-name . "CNEr")))
+ (build-system r-build-system)
+ (inputs `(("zlib" ,zlib)))
+ (propagated-inputs
+ `(("r-annotate" ,r-annotate)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-biostrings" ,r-biostrings)
+ ("r-dbi" ,r-dbi)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-go-db" ,r-go-db)
+ ("r-iranges" ,r-iranges)
+ ("r-keggrest" ,r-keggrest)
+ ("r-powerlaw" ,r-powerlaw)
+ ("r-r-utils" ,r-r-utils)
+ ("r-readr" ,r-readr)
+ ("r-reshape2" ,r-reshape2)
+ ("r-rsqlite" ,r-rsqlite)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-xvector" ,r-xvector)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/ge11232002/CNEr")
+ (synopsis "CNE Detection and Visualization")
+ (description
+ "This package provides tools for large-scale identification and
+advanced visualization of sets of conserved noncoding elements.")
+ ;; For all files in src/ucsc "license is hereby granted for all use -
+ ;; public, private or commercial"; this includes those files that don't
+ ;; have a license header, because they are included in the free parts of
+ ;; the kentutils package.
+ (license (list license:gpl2
+ (license:non-copyleft
+ "https://raw.githubusercontent.com/ucscGenomeBrowser/kent/v410_base/src/lib/LICENSE")))))
+
(define-public r-singlecellexperiment
(package
(name "r-singlecellexperiment")