summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2020-12-16 23:17:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-17 11:26:53 +0100
commiteb2f1a7dd94d816cfe5741f4053fc7e9d87eb8f4 (patch)
tree219faa8b160546d85ed73bf7a61e70d8602b0858 /gnu/packages/bioconductor.scm
parent1b02b12c05fc684c58e8371f9f6db4f4943074e3 (diff)
gnu: Add r-gagedata.
* gnu/packages/bioconductor.scm (r-gagedata): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 85ee56c539..76c1423bc9 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1103,6 +1103,32 @@ examples' of Affymetrix data, unlike the artificial examples included in the
package @code{affy}.")
(license license:gpl2+)))
+(define-public r-gagedata
+ (package
+ (name "r-gagedata")
+ (version "2.28.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "gageData" version 'experiment))
+ (sha256
+ (base32 "16lmnvmbykvbdgwyx7r2jc217gb9nidn81860v5kri99g97j4jdn"))))
+ (properties `((upstream-name . "gageData")))
+ (build-system r-build-system)
+ (home-page "https://bioconductor.org/packages/gageData")
+ (synopsis "Auxillary data for gage package")
+ (description
+ "This is a supportive data package for the software package @code{gage}.
+However, the data supplied here are also useful for gene set or pathway
+analysis or microarray data analysis in general. In this package, we provide
+two demo microarray dataset: GSE16873 (a breast cancer dataset from GEO) and
+BMP6 (originally published as an demo dataset for GAGE, also registered as
+GSE13604 in GEO). This package also includes commonly used gene set data based
+on KEGG pathways and GO terms for major research species, including human,
+mouse, rat and budding yeast. Mapping data between common gene IDs for budding
+yeast are also included.")
+ (license license:gpl2+)))
+
(define-public r-coverageview
(package
(name "r-coverageview")