summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-30 13:29:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-03-30 13:29:08 +0200
commit2f9b2699b1fca180a6856c059cdbd72f77000de5 (patch)
tree3f9acb00b1806f737a1fdc2dd1829255f72c4ce1 /gnu/packages/bioconductor.scm
parent7df926ee041f304e80a952643017cf453afc5a8d (diff)
gnu: Add r-globaltest.
* gnu/packages/bioconductor.scm (r-globaltest): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 5401947a9a..7690382dc7 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -6591,6 +6591,30 @@ profiles and assignment of a status (gain, normal or loss) to each chromosomal
regions identified.")
(license license:gpl2)))
+(define-public r-globaltest
+ (package
+ (name "r-globaltest")
+ (version "5.52.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "globaltest" version))
+ (sha256
+ (base32
+ "1g5dv3bw0fj8sq0hsr8c7nh6n1rzvx1bisqlyqjqq3f8lsyb51kb"))))
+ (properties `((upstream-name . "globaltest")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-annotate r-annotationdbi r-biobase r-survival))
+ (home-page "https://bioconductor.org/packages/globaltest")
+ (synopsis
+ "Test groups of covariates for association with a response variable")
+ (description
+ "The global test tests groups of covariates (or features) for association
+with a response variable. This package implements the test with diagnostic
+plots and multiple testing utilities, along with several functions to
+facilitate the use of this test for gene set testing of GO and KEGG terms.")
+ (license license:gpl2+)))
+
(define-public r-gostats
(package
(name "r-gostats")