summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-12-27 11:02:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-02 10:19:35 +0100
commitc8e2b85ed1cbb3e17701c838db797ab718d18be0 (patch)
treedf6230e03d3e937ecd3609cf73630e3b49ccad56 /gnu/packages/bioinformatics.scm
parent7593364d70fa81b761c1d9b0269510b21364c6fa (diff)
gnu: Add r-stacas.
* gnu/packages/bioinformatics.scm (r-stacas): New variable. Change-Id: I258a315465ed88b8013d26a36718250c950aa107
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2e4bc876d4..34039b2eb5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1070,6 +1070,42 @@ of single-cell data using Seurat, RcppML nmf, SingleCellExperiments and
similar.")
(license license:gpl2+))))
+(define-public r-stacas
+ (package
+ (name "r-stacas")
+ (version "2.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/carmonalab/STACAS")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13i0h5i6vlbrb8ndq9gr81560z9d74b2c7m3rjfzls01irjza9hm"))))
+ (properties `((upstream-name . "STACAS")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biocneighbors
+ r-biocparallel
+ r-ggplot2
+ r-ggridges
+ r-pbapply
+ r-r-utils
+ r-seurat))
+ (home-page "https://github.com/carmonalab/STACAS")
+ (synopsis "Sub-type anchoring correction for alignment in Seurat")
+ (description
+ "This package implements methods for batch correction and integration of
+scRNA-seq datasets, based on the Seurat anchor-based integration framework.
+In particular, STACAS is optimized for the integration of heterogenous
+datasets with only limited overlap between cell sub-types (e.g. TIL sets of
+CD8 from tumor with CD8/CD4 T cells from lymphnode), for which the default
+Seurat alignment methods would tend to over-correct biological differences.
+The 2.0 version of the package allows the users to incorporate explicit
+information about cell-types in order to assist the integration process.")
+ (license license:gpl3)))
+
(define-public r-stringendo
(let ((commit "15594b1bba11048a812874bafec0eea1dcc8618a")
(revision "1"))