summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-01 00:30:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:16 +0200
commite9d70b85ebc7088629d6b513da3d48a95e4ec75c (patch)
treed87d9a172618bdcce6f37efd8a0d02702cd3eb07 /gnu/packages/bioinformatics.scm
parent24bf2329a4bca391f3f44cca31e1b4e1fd9b22e6 (diff)
gnu: python-biom-format: Untangle from python-scikit-bio.
* gnu/packages/bioinformatics.scm (python-biom-format)[arguments]: Add phase 'pandas-compatibility; disable tests that need sciki-bio. [propagated-inputs]: Remove python-scikit-bio. Change-Id: Ifd528d256a1c75962fb05aef5602edbf67a5af26
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8cae47a9da..4b6d85dfba 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2935,6 +2935,11 @@ use-case, we encourage users to compose functions to achieve their goals.")
'(modify-phases %standard-phases
(add-after 'unpack 'use-cython
(lambda _ (setenv "USE_CYTHON" "1")))
+ (add-after 'unpack 'pandas-compatibility
+ (lambda _
+ (substitute* "biom/tests/test_table.py"
+ (("import pandas.util.testing")
+ "import pandas.testing"))))
(add-after 'unpack 'disable-broken-tests
(lambda _
(substitute* "biom/tests/test_util.py"
@@ -2946,6 +2951,24 @@ use-case, we encourage users to compose functions to achieve their goals.")
(("^(.+)def test_from_hdf5_issue_731" m indent)
(string-append indent
"@npt.dec.skipif(True, msg='Guix')\n"
+ m))
+ ;; Unclear why this one fails. There is no backtrace.
+ (("^(.+)def test_to_dataframe_is_sparse" m indent)
+ (string-append indent
+ "@npt.dec.skipif(True, msg='Guix')\n"
+ m))
+ ;; These need skbio, but that neeeds biom-format.
+ (("^(.+)def test_align_tree_intersect_obs" m indent)
+ (string-append indent
+ "@npt.dec.skipif(True, msg='Guix')\n"
+ m))
+ (("^(.+)def test_align_tree_intersect_tips" m indent)
+ (string-append indent
+ "@npt.dec.skipif(True, msg='Guix')\n"
+ m))
+ (("^(.+)def test_align_tree_sample" m indent)
+ (string-append indent
+ "@npt.dec.skipif(True, msg='Guix')\n"
m))))))))
(propagated-inputs
(list python-anndata
@@ -2955,7 +2978,7 @@ use-case, we encourage users to compose functions to achieve their goals.")
python-h5py
python-numpy
python-pandas
- python-scikit-bio
+ ;;python-scikit-bio ;mutually recursive dependency
python-scipy))
(native-inputs
(list python-cython python-pytest python-pytest-cov python-nose))