summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authornafkhamdc <navid.afkhami@mdc-berlin.de>2024-02-14 20:27:46 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-02-15 11:53:29 +0100
commitfb79e589957880c95bb4e8e57e2a5023c8a696d6 (patch)
tree3d8baf72561b9e2a994b437c8c6eb53c71e8ff17 /gnu/packages/bioinformatics.scm
parent06014750338159a03a6374d7ebdd783c210b3715 (diff)
gnu: Add python-ega-download-client.
* gnu/packages/bioinformatics.scm (python-ega-download-client): New variable. Change-Id: I3233774975989f912281ab2e6ec6ad3362cae18b Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bcfe3c2656..84577ef760 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2525,6 +2525,45 @@ Python.")
;; licensed lgpl2.1+
(license (list license:expat license:lgpl2.1+))))
+(define-public python-ega-download-client
+ (package
+ (name "python-ega-download-client")
+ (version "5.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/EGA-archive/ega-download-client")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0k9rfq2yyvfxs5sq9lsm8krp9ddx4s18hv85ikf3b37zv24kpwjk"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ '(list "-k"
+ ;; These tests fail because they require internet access.
+ (string-append "not test_download.py"
+ " and not test_htsget.py"
+ " and not test_commands.py"))
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("==") ">=")))))))
+ (propagated-inputs (list python-htsget python-psutil python-requests
+ python-tqdm python-urllib3))
+ (native-inputs (list python-coverage python-pytest python-pyfakefs
+ python-responses))
+ (home-page "https://github.com/EGA-archive/ega-download-client")
+ (synopsis "EGA download client")
+ (description
+ "PyEGA3 is a tool for viewing and downloading files from authorized EGA
+datasets.")
+ (license license:asl2.0)))
+
(define-public python-scdamandtools
(package
(name "python-scdamandtools")