summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2023-10-22 20:21:59 +0100
committerArun Isaac <arunisaac@systemreboot.net>2024-02-22 13:02:43 +0000
commit1de86105ab695ea7720fbd4cd2f976fc543188fb (patch)
treeea35686624f77e3e53242a1da9d24d3d50af0c58 /gnu/packages/bioinformatics.scm
parent4e6b7f4c4505ce0a92544207e772d349c54dcc29 (diff)
gnu: Add python-cwl-utils.
* gnu/packages/bioinformatics.scm (python-cwl-utils): New variable. Change-Id: I9347c80c0e866b89a7d432091fbcf1bc009209a5 Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 765a5a2b4c..b38b2835fb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5182,6 +5182,49 @@ code formatter. It outputs CWL in a standardized YAML format.")
and v1.1 to v1.2.")
(license license:asl2.0)))
+(define-public python-cwl-utils
+ (package
+ (name "python-cwl-utils")
+ (version "0.32")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cwl-utils" version))
+ (sha256
+ (base32
+ "06wkw8d8cqm3hnz8xwnysz874gwaym36c358cr7frw5iglhvsj98"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "-k"
+ (string-append "not test_graph_split"
+ " and not test_load_document_with_remote_uri"
+ " and not test_remote_packing"
+ " and not test_remote_packing_github_soft_links"
+ " and not test_value_from_two_concatenated_expressions"))))
+ (inputs
+ (list node))
+ (native-inputs
+ (list python-mypy-extensions
+ python-pytest
+ python-pytest-mock
+ python-pytest-runner))
+ (propagated-inputs
+ (list python-cwl-upgrader
+ python-cwlformat
+ python-packaging
+ python-rdflib
+ python-requests
+ python-ruamel.yaml
+ python-schema-salad))
+ (home-page "https://github.com/common-workflow-language/cwl-utils")
+ (synopsis "Python utilities for CWL")
+ (description "@code{python-cwl-utils} provides python utilities and
+autogenerated classes for loading and parsing CWL v1.0, CWL v1.1, and CWL v1.2
+documents.")
+ (license license:asl2.0)))
+
(define-public cwltool
(package
(name "cwltool")