summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-02-28 11:34:03 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-28 11:35:27 +0200
commitaa1d419586c387ba07f323196bfb92b6237b032e (patch)
tree66ca756b605118ed0e0b89b94df2aa7d54b04921 /gnu/packages/bioinformatics.scm
parent8c0282cf543fe205a5b89201cd7bb8889121a07c (diff)
gnu: bowtie1: Update to 1.3.1.
* gnu/packages/bioinformatics.scm (bowtie1): Update to 1.3.1. [arguments]: Add test-target. [inputs]: Use newer tbb. Change-Id: I7af6aa248e5db9f91ce84fba9ba741621b110479
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3f12b28058..1613961c64 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015, 2016, 2018, 2019, 2020 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2020, 2021 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2016-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2016, 2018 Raoul Bonnal <ilpuccio.febo@gmail.com>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -3756,14 +3756,14 @@ gapped, local, and paired-end alignment modes.")
(define-public bowtie1
(package
(name "bowtie1")
- (version "1.3.0")
+ (version "1.3.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/bowtie-bio/bowtie/"
version "/bowtie-" version "-src.zip"))
(sha256
(base32
- "11dbihdnrizc6qhx9xsw77w3q5ssx642alaqzvhxx32ak9glvq04"))
+ "0q87nhgj9wrnbazcpvqp4594hmyh1isi3s9b2wlghvl4afm1fdg2"))
(modules '((guix build utils)))
(snippet
'(substitute* "Makefile"
@@ -3772,7 +3772,8 @@ gapped, local, and paired-end alignment modes.")
(("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\"")))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no "check" target
+ `(#:tests? #f ; Tests need various perl modules
+ #:test-target "simple-test"
#:make-flags
,#~(list "CC=gcc" "all"
(string-append "prefix=" #$output))
@@ -3780,7 +3781,7 @@ gapped, local, and paired-end alignment modes.")
(modify-phases %standard-phases
(delete 'configure))))
(inputs
- (list python-wrapper tbb-2020 zlib))
+ (list python-wrapper tbb zlib))
(supported-systems '("x86_64-linux"))
(home-page "https://bowtie-bio.sourceforge.net/index.shtml")
(synopsis "Fast aligner for short nucleotide sequence reads")